Connectrix B-Series: Kun fabric-käyttöjärjestelmä on päivitetty versioon 9.1.1c, Inline-komennot, joissa käytetään komentoa fosexec, palauttavat virheen

摘要: Kun olet päivittänyt Fabric OS (FOS) 9.1.1c -versioon, uniX- tai Linux-palvelimen inline-komentoja ei voi suorittaa kytkimeen fosexec-komennoilla.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Ympäristö:

Fabric OS 9.1.1c

Ongelma:

Tuloksissa näkyy virheitä, kun Inline-komento suoritetaan UNIX- tai Linux-palvelimessa. Komento lakkaa vastaamasta, kun samassa kotelossa tutkitaan eri loogista kytkimenOSAA. Esimerkki:

[hosttest@VM1234 ~]$
[hosttest@VM1234 ~]$ ssh aa.bb.cc.dd fosexec --fid 44 -cmd 'firmwareshow'
hosttest@aa.bb.cc.dd's password:
/bin/stty: 'standard input': Inappropriate ioctl for device
/bin/stty: 'standard input': Inappropriate ioctl for device
/etc/ssh_inline_profile: line 25: FUNCNEST: readonly variable
Appl     Primary/Secondary Versions
------------------------------------------
FOS      v9.1.1c
         v9.1.1c
---------------------------------------------------

"firmwareshow" on FID 44:

[hosttest@VM3198 ~]$

原因

Ongelma havaittiin sisäisen testauksen aikana. Virheen muutos havaittiin, kun FOS 9.2.0a -päivitys tehtiin.

Virhe:
[hosttest@VM3198 ~]$
[hosttest@VM3198 ~]$ ssh aa.bb.cc.dd fosexec --fid 44 -cmd 'firmwareshow'
hosttest@10.60.23.25's password:
/bin/stty: 'standard input': Inappropriate ioctl for device
/bin/stty: 'standard input': Inappropriate ioctl for device
Appl     Primary/Secondary Versions
------------------------------------------
FOS      v9.2.0a
         v9.2.0a
---------------------------------------------------

"firmwareshow" on FID 44:

[hosttest@VM3198 ~]$

解析度

Ratkaisu:

Päivitä Fabric OS 9.2.0b -versioon tai uudempaan.

Kiertotapa:

Suorita komennot suoraan kytkimessä.

其他資訊

Katso brocade-VIAN FOS-850854 ja VIALLINEN FOS-844429- artikkeli, joissa käsitellään tätä ongelmaa.

受影響的產品

Connectrix, Connectrix B-Series

產品

Connectrix B-Series Fabric OS 9.X
文章屬性
文章編號: 000218645
文章類型: Solution
上次修改時間: 29 7月 2025
版本:  4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。