CloudLink: Får felmeddelandet "Det går inte att hämta det begärda certifikatet"
摘要: När du försöker upprätta förtroende för CloudLink i vCenter visas felmeddelandet "Det går inte att hämta det begärda certifikatet".
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
I vCenter går det inte att upprätta förtroende till CloudLink under den första konfigurationen av nyckelprovidern.
Få ett felmeddelande enligt nedan:
Få ett felmeddelande enligt nedan:
Cannot retrieve the requested certificate
原因
En orsak till det här felet är att vCenter inte kan kommunicera med CloudLink via port 5696.
En annan möjlig orsak är att användaren kör versioner av CloudLink och vCenter som inte är kompatibla.
En annan möjlig orsak är att användaren kör versioner av CloudLink och vCenter som inte är kompatibla.
解析度
- SSH-ansluta till vCenter-enheten
- Kör följande kommandon:
ping cloudlinkip curl -v telnet://cloudlinkip:5696 curl -v --local-port 10000 telnet://cloudlinkip:5696 curl -v --local-port 20000 telnet://cloudlinkip:5696 curl -v --local-port 30000 telnet://cloudlinkip:5696 curl -v --local-port 40000 telnet://cloudlinkip:5696 curl -v --local-port 50000 telnet://cloudlinkip:5696 curl -v --local-port 60000 telnet://cloudlinkip:5696
- Om ping - eller curl-kommandona misslyckas kan det tyda på ett brandväggs- eller nätverksproblem. Användaren bör kontrollera med nätverksteamet och se till att de nödvändiga portarna är öppna och bekräfta att de virtuella CloudLink-datorerna är anslutna till rätt nätverk eller VLAN.
- Om curl-kommandona lyckas tas ett meddelande emot med texten "Ansluten till x.x.x.x" enligt den här skärmbilden:
- Om ping- och curl- eller telnet-kommandona lyckas kontrollerar du att CloudLink- och vCenter-versionerna är kompatibla. Du kan få felmeddelandet Det går inte att hämta det begärda certifikatet om vCenter 8.x med CloudLink 7.1.7 eller tidigare används. I VMware Compatibility Guide
finns information om vilka vCenter- och CloudLink-versioner som stöds
CloudLink 7.0 stöds med vCenter 6.x och 7.x.
CloudLink 7.1.x stöds med vCenter 6.x och 7.x.
CloudLink 8.x stöds med vCenter 7.x och 8.x.
CloudLink 8.x är den version som officiellt stöds med vCenter 8.x, men CloudLink 7.1.8 och 7.1.9 verkar fungera med vCenter 8.x.
CloudLink 7.1.x stöds med vCenter 6.x och 7.x.
CloudLink 8.x stöds med vCenter 7.x och 8.x.
CloudLink 8.x är den version som officiellt stöds med vCenter 8.x, men CloudLink 7.1.8 och 7.1.9 verkar fungera med vCenter 8.x.
- Uppgradering av CloudLink till 7.1.8, 7.1.9 eller 8.x bör lösa problemet och kunna skapa förtroende.
Friskrivning: Om användaren kör PowerFlex kanske hen inte kan uppgradera till vissa versioner av CloudLink. De måste behålla den CloudLink-version som anges i RCM-konfigurationen.
受影響的產品
CloudLink文章屬性
文章編號: 000223969
文章類型: Solution
上次修改時間: 13 11月 2025
版本: 4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。