ECS: Zápis velkých souborů selhává s 500 chybami pro protokol S3

摘要: Zápis velkých souborů selhává s 500 chybami pro protokol S3.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Zápis velkých souborů (více GB nebo větších) pomocí protokolu S3 selhává s 500 chybami.

原因

Pomocí příkazu "HTTP PUT" nebo "HTTPS PUT" zapište soubory do systému ECS. Příkaz S3 PUT nepřidá objekt částečně, požadavek je úspěšný nebo neúspěšný zápis (všechno nebo nic).

Vzhledem k tomu, že se jedná o operaci "všechno nebo nic", jakékoli přerušení přenosu dat velkého souboru má za následek úplné selhání tohoto zápisu. Jediným prostředkem pro toto selhání je zopakovat celou operaci zápisu a doufat, že při příštím pokusu proběhne úspěšně.

解析度

U velkých souborů (GB a větších) se doporučuje místo operace PUT použít funkci MPU (Multi Part Uploads). Toto doporučení se provádí, aby se zabránilo dlouhým časům dokončení zápisu (100 MB nebo více, podle osvědčených postupů AWS).

Příklad:
Soubor o velikosti 80 GB bude rozdělen na bloky a každý kus je odeslán do systému ECS. Pokud se nahrávání některé části nezdaří, bude se opakovat pouze nahrání jedné části, nikoli celého objektu.  
Očekává se, že výkon MPU bude lepší než u jednoho velkého PUT, protože operace MPU mohou být vícevláknové. Výsledkem je, že použití MPU lépe využívá více připojení a šířku pásma. To znamená, že současně lze odeslat více než jednu část, což zlepšuje celkový výkon při zápisu velkých souborů.

其他資訊

Zdroje pro vývojáře aplikací, kteří přecházejí z PUT na MPU:
TransferManager (AWS SDK pro Java – 1.12.588) (amazon.com)Tento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.

Přehled AWS MPU: (včetně osvědčených postupů pro MPU)
Nahrávání a kopírování objektů pomocí nahrávání s více částmi – služba Amazon Simple Storage ServiceTento hypertextový odkaz vás zavede na webové stránky mimo společnost Dell Technologies.

受影響的產品

ECS Appliance

產品

ECS Appliance
文章屬性
文章編號: 000048288
文章類型: Solution
上次修改時間: 08 9月 2025
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。