Avamar:ADMe 備份選取準則
摘要: 如何運用各種 ADMe 備份選擇選項來篩選要搜尋的日期範圍。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
備份選擇問題
ADMe 中的預設日期範圍可能無法滿足所有情況,導致不正確的篩選和選擇預期的備份。
使用者在從特定日期範圍內選取所需的備份時,可能會遇到困難。
- 由於預設日期範圍限制,導致備份選擇不正確
- 難以從特定日期範圍尋找想要的備份
這些問題可能會導致選取非預期的備份,進而導致潛在的資料不一致或遺失。
原因
篩選不正確
此問題是由於在篩選預期的備份時不正確所導致,這可能會導致不良結果。
- 日期範圍規範不足
- 對可用備份選擇選項瞭解不足
注意:瞭解用於篩選日期範圍的可用選項對於選擇所需的備份至關重要。
解析度
ADMe 備份選擇準則解決方案
以下顯示如何影響 ADMe/ATO 在其備份選擇階段使用的搜尋日期範圍的所有可能性。
- 默認情況下,使用的開始日期始終是當前月份的第一天到當前日期。例如,如果今天是 2014-09-15,則有效搜索範圍為 2014-09-01 到 2014-09-15。
- 語法
-sdate yyyy-mm-dd and -edate yyyy-mm-dd用於指定顯式開始和結束日期範圍。 - 語法
-rmonth #用於及時返回相對於當前月份的指定月數。 - 語法
-rmonthx #用於及時返回相對於當前月份的指定月數,但將日期範圍限製為僅該月。 - 語法
-rday #用於指定單個相對日或短天數範圍。 - 語法
-nday #用於指定可以跨越一個月或一年邊界的固定搜索天數,最多 30 天。
語法範例如下:
# Example of using -rmonth
-rmonth 1
# Example of using -rmonthx
-rmonthx 2
# Example of using -rday
-rday 25
# Example of using -nday
-nday 3
若要確認問題已成功解決,請確定已從指定的日期範圍內選取所需的備份。
注意:使用 -rmonth 和 -rmonthx 語法,因為它可能會影響搜索日期範圍。
其他資訊
使用上述任一選項來影響有效搜尋日期範圍,篩選條件例如 -first, -last, -周,或 -rtype 也可以在選擇語句中。
在將上述任何選項包含在作業策略中之前,您可以使用主功能表中的互動式選擇功能試驗上述任何選項。然後,可以使用主功能表中的“查看”功能查看生成的選擇工作清單。此程序不會導致移動備份資料,因此是確認所使用的語法是否提供預期結果的好方法。
上述所有語法均輸入 Select_Flags 行的作業原則定義中,如以下範例所示:
=========================================================
Job Policy: /atoadmin/etc/admbatch-IOmart1.cfg
================< Job Policy Contents >=================
Environment_Number:: 4
Base_Group_Name:: iomart1
Sub_Group_Numbers:: 0
Select_Flags:: -d -nday 2 -last
View_Flags:: -d
Tapeout_Flags:: -d -stageonly -D -m -inc
=========================================================
=========================================================
Job Policy: /atoadmin/etc/admbatch-IOmart1.cfg
================< Job Policy Contents >=================
Environment_Number:: 4
Base_Group_Name:: iomart1
Sub_Group_Numbers:: 0
Select_Flags:: -d -rmonth 1 -last
View_Flags:: -d
Tapeout_Flags:: -d -stageonly -D -m -inc
=========================================================
受影響的產品
Avamar, Avamar Data Migration Enabler文章屬性
文章編號: 000103694
文章類型: Solution
上次修改時間: 20 6月 2025
版本: 5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。