適用於 Windows 使用者的印表機 Spooler 錯誤疑難解答和解決方案
摘要: 瞭解如何解決 Windows 中的列印集區錯誤。瞭解如何停止並啟動列印集線器,並使用這些逐步指南對印表機問題進行故障診斷。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
出現列印多工緩衝處理器錯誤。傳送至印表機的檔不會列印,且會卡在印表機複選器中。
受影響的作業系統:
- Windows 11
- Windows 10
- Windows 8.1
- Windows 8
- Windows 7
原因
列印集區器的問題可能會導致一些列印和通訊問題。有時,重新啟動或清除列印複選器可能會解決這些問題。列印多工緩衝處理器可協助您的 Windows 電腦與印表機互動,並將佇列中的列印工作排序。
解析度
目錄:
如何手動停止及啟動列印多工緩衝處理器
- 按兩 下「開始 」按鈕,然後選取「 執行」。類型
command(圖 1),然後按下 「OK」 以顯示命令提示字元 (圖 2)。
圖 1:打字
command在「執行」視窗中
圖 2:命令提示字元
- 在命令提示字元中鍵入
net stop spooler然後按下 Enter 鍵 以停止 Print Spooler - 在命令提示字元中鍵入
net start spooler然後按下 Enter 鍵 啟動 Print Spooler
如何從多工緩衝資料夾手動刪除檔案
如果您的工作卡在列印佇列中且無法刪除,您可能必須手動刪除這些工作。
- 停止 列印分集器。
注意:如需有關如何停止印表機集合器的詳細資訊,請參閱本文的「 如何手動停止並啟動列印 Spooler 」一節。
- 流覽至
C:磁碟驅動器並加以開啟。 - 流覽至
WINDOWS並加以開啟。 - 流覽至
SYSTEM32並加以開啟。 - 流覽至
SPOOL然後選取。 - 流覽至
PRINTERS。 - 刪除 此資料夾中的所有檔案。例如,它們可能會顯示為
FP00008或FP00008.SHD。 - 啟動 Print Spooler。
注意:如需如何啟動印表機複選器的詳細資訊,請參閱本文的「 如何手動停止並啟動 Print Spooler 」一節。
如何從登錄檔中手動刪除印表機
您也可以從電腦的登錄檔中刪除印表機。如果印表機無法刪除或移除,且重新啟動列印集區尚未清除問題,請從登錄中手動移除印表機。
警告:從登錄變更或刪除檔案可能會導致操作系統發生問題,例如無法開機至 Windows。除非您願意這麼做,否則請勿修改登錄。如果登錄檔已損毀,您可能必須重新安裝 Windows 作業系統。
- 按兩 下「開始 」按鈕,然後按下 「執行」。類型
command然後按下 「OK 」以顯示命令提示字元。 - 類型
regedit然後按下 Enter 鍵。這會顯示登錄編輯器 (圖 3)。
圖 3:登錄檔編輯器
- 在登錄編輯器中,展開 計算機。
- 展開
HKEY_CURRENT_USER資料夾 (圖 4)。
圖 4:HKEY_CURRENT_USER 資料夾
- 展開 印表機 資料夾。
- 連按兩下 「Connections 」資料夾 (圖 5)。
圖 5:連線資料夾
- 僅刪除印表機佇列和印表機 (圖 6)。請勿刪除任何其他項目。
圖 6:印表機佇列和印表機
如何解決印表機多工緩衝處理器錯誤
Windows 11 和 Windows 10
- 類型
troubleshooting在 Windows 搜尋 方塊中。 - 點選 「疑難解答設定 」(控制面板)
- 按兩下「Hardware and Sound」底下的「使用印表機」。
- 按一下進階。
- 單擊 [Run as administrator] (以系統管理員身分執行)。如有詢問,請輸入您的認證,或如果您不知道認證則取消。
- 按兩下 [Next] (下一步) ,然後依照提示操作。
注意:如果問題仍然存在,您必須解除安裝並重新安裝印表機的最新印表機驅動程式。如需 Dell 印表機的詳細資訊,請參閱 Dell 知識庫文章 Dell Printer 卸載、下載和安裝印表機驅動程式、軟體、手冊和韌體。若為非 Dell 品牌印表機,請參閱印表機製造商的網站。
Windows 8.1 和 Windows 8
- 按住 Windows 鍵,然後按下鍵盤上的 Q 鍵。
- 類型
troubleshooting在搜尋方塊中。 - 按一下故障診斷。
- 按兩下「Hardware and Sound」底下的「使用印表機」。
- 按兩下 [Advance] (進階)。
- 單擊 [Run as administrator] (以系統管理員身分執行)。如有詢問,請輸入您的認證,或如果您不知道認證則取消。
- 按兩下 [Next] (下一步) ,然後依照提示操作。
注意:如果問題仍然存在,您必須解除安裝並重新安裝印表機的最新印表機驅動程式。如需 Dell 印表機的詳細資訊,請參閱 Dell 知識庫文章 Dell Printer 卸載、下載和安裝印表機驅動程式、軟體、手冊和韌體。若為非 Dell 品牌印表機,請參閱印表機製造商的網站。
Windows 7
- 按一下開始。
- 在 Windows 搜尋方塊中輸入
troubleshooting。 - 按一下「故障診斷」(應位於「控制台」下的清單頂端)。
- 按兩下「Hardware and Sound」底下的「使用印表機」。
- 按一下進階。
- 單擊 [Run as administrator] (以系統管理員身分執行)。如有詢問,請輸入您的認證,或如果您不知道認證則取消。
- 按兩下 [Next] (下一步) ,然後依照提示操作。
注意:如果問題仍然存在,您必須解除安裝並重新安裝印表機的最新印表機驅動程式。如需 Dell 印表機的詳細資訊,請參閱 Dell 知識庫文章 Dell Printer 卸載、下載和安裝印表機驅動程式、軟體、手冊和韌體。若為非 Dell 品牌印表機,請參閱印表機製造商的網站。
受影響的產品
Printers & Accessories文章屬性
文章編號: 000125904
文章類型: Solution
上次修改時間: 11 2月 2025
版本: 9
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。