EMSServiceHelper.exe does not automatically launch

摘要: Dell Data Protection | Encryption External Media Shield (EMS) user does not receive a password prompt when attempting to access data on an encrypted CD, DVD, or USB media.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Affected Products:

  • Dell Data Protection | External Media Edition
  • Dell Data Protection | Enterprise Edition
  • Dell Data Protection | Personal Edition

原因

This issue may occur when the EMSServiceHelper.exe does not load properly on an encrypted endpoint or C:\Windows\System32\EmsServicehelper.exe does not exist after an upgrade.

解析度

The issue has been resolved in 8.7.

To work around this issue, uninstall the External Media Edition application.

  1. Uninstall Dell Data Protection | Encryption (through Add/Remove or Programs and Features if available) if you installed Dell Data Protection | Encryption using a script that you must uninstall it using the same install media as the version installed.
Note: Decryption of data is not required.
  • To uninstall External Media Edition
    • Run a command line similar to the following: DDPE_XXbit_setup.exe /s /x /v"/qn /l c:\ddpe_uninstall.log"
  1. Reinstall the External Media Edition application.

Note: A temporary solution would be to overwrite the EMSServiceHelper.exe manually.
  1. Go to the EMSServiceHelper.exe found at C:\Windows\system32\EMSServiceHelper.exe.
    1. Right-click the file and choose:
      1.  Properties
      2. Then click Details.
    2. Check the details tab for missing information such as:
      1. File version
      2.  Product name
      3.  Product version
      4.  Copyright
      5. Language

Reference the figure below for an example is a corrupt EMSServiceHelper.exe file:

Corrupt EMSServiceHelper.exe
Figure 1: (English Only): Corrupt EMSServiceHelper.exe

Reference the figure below for an example of a working EMSServiceHelper.exe file:

Working EMSServiceHelper.exe
Figure 2: (English Only): Working EMSServiceHelper.exe

  1. Copy the EMSServiceHelper.exe file found at in C:\Program Files\Dell\Dell Data Protection\Encryption\EMS\EMSServiceHelper.exe.
  2. Paste it to C:\Windows\system32\EMSServiceHelper.exe to overwrite the file.
  3. Reboot the endpoint.

To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

受影響的產品

Dell Encryption
文章屬性
文章編號: 000130996
文章類型: Solution
上次修改時間: 08 1月 2024
版本:  9
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