跳至主要內容
  • 簡單快速地下訂單
  • 檢視訂單及追蹤商品運送狀態
  • 建立並存取您的產品清單
  • 使用「公司管理」來管理您的 Dell EMC 網站、產品和產品層級連絡人。

Dell Command Warranty 公用程式 5.1 版和舊版失敗

摘要: 請參閱有關在 Dell Command |版本 5.1 及更舊版本時解決問題的資訊Warranty Utility 工具已無法使用。

本文可能採用自動翻譯。如果您對翻譯品質有任何寶貴意見,請使用此頁面底部的表單告訴我們,謝謝。

文章內容


症狀

您遇到失敗併發生錯誤。

原因

N/A

解析度


Dell Command Warranty 公用程式 5.1 版和舊版失敗

  1. 問題
  2. 描述名稱
  3. 解決方案

問題

版本 5.1 及較舊的 Dell Command |Warranty Utility 工具已無法使用。失敗並出現以下錯誤訊息,您必須檢查公用程式記錄檔:

Error: 請檢查記錄檔以取得更多資訊:C:\Program Files (x86)\Dell\CommandIntegrationSuite\Logs\Warranty.log。

Dell Command |Warranty Utility 是 Dell Command | 的一項功能Integration Suite for System Center (又名 Dell Command |Integration Suite for System Center)。最新版本的 Dell Command |Integration Suite for System Center 和保固公用程式為 5.2。Dell Command |Integration Suite for System Center 5.2 版于 2019 年 12 月開始出貨。

回到頁首

描述名稱

Dell Warranty 公用程式是命令列介面 (CLI) 工具。您可以執行下列操作來執行公用程式:

  • 安裝 Dell Command |Integration Suite for System Center 5.1 (例如)。
  • 在命令方塊中,流覽 Dell Command | 的下列安裝資料夾Integration Suite for System Center:

    C:\Program Files (x86)\Dell\CommandIntegrationSuite

  • 建立並填入 CSV 檔案,其中包含產品服務編號清單。例如,建立名為 ServiceTagsInput80.csv 的檔案,在檔案中加入一組產品服務編號,並將其置於您選擇的某個資料夾位置,例如下列範例位置:

    C:\Temp\Warranty

  • 在命令方塊中輸入並執行下列命令列:

    ./DellWarranty-CLI.exe /v /I=C:\Temp\Warranty\ServiceTagsInput.csv

如果是 Dell 保固公用程式 5.1 版或更舊版本,則公用程式會失敗。

以下是故障的徵兆:

  • 保固公用程式故障,並顯示下列訊息:(請參閱圖 1)

    Error: 請檢查 記錄檔以取得更多資訊:C:\Program Files (x86)\Dell\CommandIntegrationSuite\Logs\Warranty.log。
    錯誤訊息
    圖 1 - 錯誤訊息

  • 當保固公用程式故障時,電腦上的公用程式記錄檔包含下列行 ,如記錄檔結尾的行:
    :-------------------------------------------------------------------------------------------
    : 記錄檔:C:\ProgramData\Dell\CommandIntegrationSuite\Logs\warranty.log:
    記錄層級:正常
    :產品名稱:Dell Command |Integration Suite for System Center - 保固
    :產品版本:5.1.0.80:
    作業系統:Microsoft Windows NT 6.2.9200.0:

    :-------------------------------------------------------------------------------------------
    : 日期:20191216024432
    WARRCLI-M01:DellWarranty-CLI 起始 **
    DC-GSTF02:在 C:\Temp\Warranty\ServiceTagsInput.csv
    240 DC-DWRE04 中找到的產品服務編號:擷取保固資料時發生錯誤

    DC-DWRE04 發生錯誤 (System.ArgumentNullException):
    值不可為 null。
    參數名稱:來源

關鍵記錄行為:

DC-DWRE04:擷取保固資料
時發生錯誤DC-DWRE04 的錯誤 (System.ArgumentNullException)

5.1 版和較舊版的保固工具現已失敗,因為在公用程式 5.2 版之前,Dell 保固公用程式所依賴的保固服務已無法再使用。


回到頁首


解決方案

解決方案是升級至最新版本的 Dell Command |Integration Suite for System Center。Dell Command | 中的保固公用程式Integration Suite for System Center 5.2 和更新版本使用的保固服務較版本 5.1 和較舊的公用程式更舊。

注意:如需有關如何下載驅動程式的詳細資訊,請參閱 Dell 知識庫文章「驅動程式與下載常見問題」。

升級至最新版本的 Dell Command |Integration Suite for System Center,執行的命令列與執行公用程式前所執行的命令列相同。但在這種情況下,公用程式應該會成功。(請參閱圖 2)
成功
圖 2 - 成功

 

此外,匯出的 CSV 檔案應包含有效的保固資料。
返回頂部

文章屬性


受影響的產品

Desktops & All-in-Ones, Laptops

上次發佈日期

07 1月 2022

版本

4

文章類型

Solution