NVP vProxy:虚拟机备份失败并显示“VDDK Error:13: 您没有此文件的访问权限...Unable to open virtual disk in hotadd mode“(无法在 hotadd 模式下打开虚拟磁盘)

摘要: 当 vProxy 对虚拟机文件没有数据存储区访问权限时,为 hotadd 访问配置的虚拟机备份仅失败,并显示 VDDK 错误 13“您没有对此文件的访问权限”。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

NVP vProxy 仅支持“hotadd”和“nbd”传输模式。

NVP vProxy 虚拟机备份失败,并显示以下错误:
YYYY/MM/DD HH:MM:SS TRACE:  [@(#) Build number: ###] Opening source VMDK "[DATASTORE] VM_NAME/VM_NAME.vmdk" ...
YYYY/MM/DD HH:MM:SS INFO:   [@(#) Build number: ###] Calling VixDiskLib_Open("[DATASTORE] VM_NAME/VM_NAME.vmdk")...
YYYY/MM/DD HH:MM:SS ERROR:  [@(#) Build number: ###] VDDK Error: 13: You do not have access rights to this file.
YYYY/MM/DD HH:MM:SS ERROR:  [@(#) Build number: ###] Failed to open source VMDK "[DATASTORE] VM_NAME/VM_NAME.vmdk".
YYYY/MM/DD HH:MM:SS ERROR:  [@(#) Build number: ###] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR:  [@(#) Build number: ###] "Hard disk 1": BackupVmdk: "Hard disk 1": Unable to open Virtual Disk "[DATASTORE] VM_NAME/VM_NAME.vmdk" in "hotadd" mode.
YYYY/MM/DD HH:MM:SS ERROR:  [@(#) Build number: ###] "Hard disk 1": BackupVmdk: Failed backup.
YYYY/MM/DD HH:MM:SS ERROR:  [@(#) Build number: ###] Unable to backup virtual disk "Hard disk 1".

原因

默认情况下,使用“hotadd”传输模式。如果 vProxy 无法直接访问虚拟机正在运行的数据存储区,它将回退到使用 NBD 模式,以提高获得成功备份的机会;但是,如果 NBD 处于禁用状态(在 vProxy 属性中设置为 0),则备份将失败。

Hotadd VMware 备份应用装置或外部代理直接装载虚拟机的硬盘以读取备份数据。此模式要求代理可以直接访问要备份的虚拟机的数据存储区。
NBD VMware 备份应用装置或外部代理将连接到虚拟机通过 IP 网络运行的 ESX 服务器,数据将通过 IP 网络传输到代理。因此,NBD 模式通常比 hotadd 模式慢。

解析度

要支持 hotadd 模式,请在具有用于备份的目标虚拟磁盘的存储路径的 ESXi 主机上部署 vProxy。Hotadd 模式需要 VMware 硬件版本 7 或更高版本。



在 vProxy 主机上启用 NBD(在 vProxy 属性中)。建议在 nbd 上使用 hotadd,因为 hotadd 通常具有更好的性能,并且 nbd 利用 ESXi 主机的管理网络。

有关“性能和可扩展性”建议,请参阅 NetWorker 版本的“NetWorker VMware 集成指南”。此文档可通过以下方法获得:https://www.dell.com/support/home/product-support/product/networker/docs

受影響的產品

NetWorker

產品

NetWorker
文章屬性
文章編號: 000160825
文章類型: Solution
上次修改時間: 05 6月 2025
版本:  4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。