Avamar: LDAP'yi sıfırdan yapılandırma (grup tabanlı)

摘要: Avamar: Basit Dizin Erişim Protokolü'nü (LDAP) sıfırdan yapılandırma (grup tabanlı)

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Çalışmayan LDAP yapılandırmasını kaldırarak LDAP'yi sıfırdan yapılandırın.

Yanlış yapılandırılmış ldap.properties veya krb5.conf dosyaları nedeniyle LDAP oturum açma işlemi yapılamıyor.

原因

Ldap.properties veya Krb5.conf dosyaları manuel olarak yanlış şekilde değiştirilmiştir.

解析度

LDAP'yi sıfırdan yapılandırmak için aşağıdaki adımları izleyin:

  1. Yardımcı yazılım düğümünde kök olarak oturum açın.
  2. Mevcut ldap.properties ve krb5.conf dosyalarının yedeğini alın

     a) mv /usr/local/avamar/etc/ldap.properties /usr/local/avamar/etc/ldap.properties.'date -I'
b) mv /usr/local/avamar/etc/krb5.conf /usr/local/avamar/etc/krb5.conf.'date -I'

  1. Avamar Administrator kullanıcı arayüzünde oturum açın ->LDAP Yönetimi ->Dizin hizmeti ekleyin ->Etki alanı adını girin (unutmayın, bu DC'nin FQDN'si değildir; yalnızca etki alanı adını girin)
  2. Başarıyla eklendikten sonra ldap.properties dosyasını düzenleyip şu satırları ekleyin: 

     ldap.search.results.per.page=1000
mcgui.trace=true

  -- Dosyayı kaydedin ve kapatın.

  1. Şimdi kullanıcı arayüzünden (Avamar Administrator-LDAP> Yönetimi -> Test Dizini Hizmeti) testi çalıştırın.
    Ardından grubu LDAP eşlemelerine ekleyin.
  2.  Avamar administrator-Hesap>Yönetimi->LDAP eşlemeleri ->sağ panelde etki alanına sağ tıklayın ->LDAP eşlemelerine grup ekleyin (arama yaparken domain* gibi joker karakterler kullanın).
  3. Grup eklendikten sonra Avamar kullanıcı arayüzünde LDAP Kullanıcısı ile oturum açmayı deneyin (Kullanıcı adı username@domainname olmalıdır).
  4. Test başarılı olmazsa:

6.1.x sürümü için:
     Kök kullanıcı olarak putty ile yardımcı yazılım düğümünde oturum açın ve şu komutu çalıştırın:

      avldap --testmcgui

       Grup seçeneği istendiğinde şunu girin: A*

Sürüm 7.x için:

Kullanılacak bir komut satırı test aracı yok. Check /usr/local/avamar/var/mc/server_log/userauthentication.log
 

  1. Şu çıktıyla daha fazla sorun giderme için PR'yi yükseltin:

    avldap --testmcgui (6.1.x sürümü için)

veya

/usr/local/avamar/var/mc/server_log/userauthentication.log (sürüm 7 için)

grep -v "#\|^$" /usr/local/avamar/etc/ldap.properties

grep -v "#\|^$" /usr/local/avamar/etc/krb5.conf        

受影響的產品

Avamar
文章屬性
文章編號: 000163513
文章類型: Solution
上次修改時間: 08 5月 2025
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。