NVP-vProxy-återställning misslyckas med "VDDK-fel: 13: Du har inte åtkomsträttigheter till den här filen"

摘要: Återställningssessionen kan inte slutföras med "Det gick inte att initiera blockskrivaren" och "Du har inte åtkomstbehörighet till den här filen".

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

NetWorker VMware Protection-lösningen (NVP) är konfigurerad med vProxy Appliance. NetWorker Management Console (NMC) används för att utföra en återställning av virtuella maskiner (VM). Loggen för återställningssessionen visar:
...
YYYY-MM-DD HH:MM:SS INFO:   [123] Setting up session for 'Hard disk 1' with backing file '[DATASTORE_NAME] VM_NAME/VM_NAME.vmdk'.
YYYY-MM-DD HH:MM:SS INFO:   [123] Data Mover: Moving data for 1 virtual disks, 1 at a time ...
YYYY-MM-DD HH:MM:SS INFO:   [123] Data Mover: Hard disk 1: Preparing for data movement.
YYYY-MM-DD HH:MM:SS ERROR:  [123] Data Mover: Hard disk 1: VDDK: Failed to open source VMDK '[DATASTORE_NAME] VM_NAME/VM_NAME.vmdk': VDDK Error: 13: You do not have access rights to this file.
YYYY-MM-DD HH:MM:SS ERROR:  [123] Data Mover: Hard disk 1: Failed to initialize Block Writer.
YYYY-MM-DD HH:MM:SS WARN:   [123] Data Mover: Hard disk 1: Warnings attempting to close target data file 'DEVICE_NAME/DEVICE_NAME/32/32/30ca2c29-00000006-95077d15-5f077d15-216c0e00-123c561e/vm-40545-disk-key-3000-flat.vmdk'.
YYYY-MM-DD HH:MM:SS WARN:   [123] Data Mover: Hard disk 1: Warning occured while releasing reader resources: Warnings attempting to close target data file 'DEVICE_NAME/DEVICE_NAME/32/32/30ca2c29-00000006-95077d15-5f077d15-216c0e00-123c561e/vm-40545-disk-key-3000-flat.vmdk'.
YYYY-MM-DD HH:MM:SS INFO:   [123] Data Mover: Hard disk 1: Cleaned up after data movement.
YYYY-MM-DD HH:MM:SS ERROR:  [123] Unable to move data for 'Hard disk 1'.
...

/opt/emc/vproxy/runtime/logs/vrecoverd/vrecoverd-vddk.log visar: 
...
YYYY-MM-DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: Unable to locate appropriate transport mode to open disk. Error 13 (You do not have access rights to this file) (Mounting 42370ba2-b24c-0f51-8990-872f1e8c8b15 using transport hotadd failed : SupportHotAddTransport: Cannot use hotadd transport to mount Virtual Machines with disks that are not SCSI, SATA or NVME (adapter type: ide).) at 5613.
YYYY-MM-DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [DATASTORE_NAME] VM_NAME/VM_NAME.vmdk. Error 13 (You do not have access rights to this file) (Mounting 42370ba2-b24c-0f51-8990-872f1e8c8b15 using transport hotadd failed : SupportHotAddTransport: Cannot use hotadd transport to mount Virtual Machines with disks that are not SCSI, SATA or NVME (adapter type: ide).) at 5769.
YYYY-MM-DD HH:MM:SS NOTICE: VDDK INFO VixDiskLib: VixDiskLib_Open: Cannot open disk [DATASTORE_NAME] VM_NAME/VM_NAME.vmdk. Error 13 (You do not have access rights to this file) at 5813.
...

原因

Konfigurationen av den virtuella datorn innehåller en virtuell IDE-disk. VMware Hot Add Transport stöder inte IDE-diskar, så VMware Network Block Device (NBD) Transport måste användas för återställningen. Återställningen konfigureras mot en vProxy som är konfigurerad med Hot Add Transport-sessioner och inga NBD Transport-sessioner.

解析度

Säkerhetskopiering/återställning av IDE-diskar stöds med NDB-transportläget. Redigera konfigurationen för en vProxy-enhet för att utföra återställningen med en NBD-session.  
  1. Öppna NetWorker Management Console (NMC).
  2. Välj fliken "Devices".
  3. I den vänstra trädvyn väljer du "VMware Proxies".
  4. I den högra rutan öppnar du egenskaperna för en vProxy i målåterställningsklustret.
  5. I Windows för egenskaper för NSR VMware-proxy väljer du fliken "Configuration".
  6. Öka antalet Maximum NBD sessions så att det matchar Maximum Hot Add-sessioner.
  7. Utför VM-återställningen med vProxy konfigurerad med NBD-sessioner.
  8. När återställningen är klar ändrar du "Maximalt antal NBD-sessioner" till noll för att endast använda transportsessioner för frekvent tillägg för säkerhetskopieringar.

其他資訊

文章屬性
文章編號: 000196669
文章類型: Solution
上次修改時間: 12 11月 2025
版本:  3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。