NetWorkerコンソール: 「ポート5672のホスト「NetWorkerサーバー」へのソケット接続を開くことができません」

摘要: [モニタリング]タブでワークフローの詳細を表示しようとすると、NetWorker管理コンソール(NMC)に次のエラー メッセージが表示されます。「Message Bus unable to open socket connection to host "Networkerserver_hostname" on port 5672: ソケット エラーが発生しました」というメッセージがNMCに表示されます。 ...

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

NetWorkerサーバーとNMC(NetWorker管理コンソール)は、同じホストにインストールされます。

NMCのモニタリングウィンドウには、すべてのポリシーが「実行しない」と表示されます イメージを実行しない。ただし、バックアップ ジョブとクローン ジョブはスケジュールに従って完了しています。

ワークフローまたはアクションのプロパティを開こうとすると、NMCに次のエラーが表示されます。
Message bus unable to open socket connection to host "<NetWorker server hostname>" on port 5672: A socket error occurred

エラー メッセージのスクリーンショット: ポート5672のホストへのソケット接続を開くことができません
図1: エラー メッセージのスクリーンショット: ポート5672のホストへのソケット接続を開くことができません。

RabbitMQは、SSL経由の通信にポート5671を使用します

ポート5672は、非SSL通信に使用されていた古いポートでした(使用されなくなりました)

GSTDはRabbitMQに接続し、ポート5671を使用してNMC情報を取得および表示します

ポート5671経由の接続に失敗すると、NetWorker NMCはフェールバックして5672を試行しますが、RabbitMQがこのポートを使用しなくなるため、接続も失敗します。

エラー メッセージでは、ポート5672に問題があることが報告されますが、実際にはポート5671との通信時に問題が発生しています。

原因

GSTDがポート5671.

でRabbitMQと通信できない通常、これはRabbitMQサービスがダウンしていることを意味しますが、このポートに何らかの接続の問題があることを意味する可能性があります(記事210569で説明されているように)。
  1. RabbitMQが正常に動作している場合は、NetWorkerサーバーのポート5671がリスニング状態である必要があります。ポート 5671 がリスニング状態であることを確認します。これらのポートを確認するには、次のコマンドを使用します。
For Linux: 
netstat -ano | grep 5671 
ss -ano | grep 5671

For Windows: 
netstat -ano | findstr 5671
  1. ポートが表示されない場合は、NSRDサービスが実行されていることを確認します(したがって、RabbitMQがこのポートへの接続を開いている必要があります)。

解析度

手順:
  1. NetWorkerサービスを停止します
  2. /nsr/tmpフォルダーに移動し、RabbitMQフォルダーの名前をRabbitMQ_oldに変更します。
  3. NetWorkerサービスを開始します。新しいRabbitMQフォルダーが/nsr/tmpフォルダーに生成されていることを確認します。 
  4. NetWorkerサーバーのポート5671のステータスを確認します
  5. NetWorker Management Consoleを開き、ワークフローのステータスを確認します。
  6. 問題が解決した場合は、/nsr/tmpからRabbitMQ_oldを削除します。

其他資訊

接続テスト コマンド:
Linux: 
curl -kv <NetWorker server>:5671
openssl s_client -connect <NetWorker server>:5671

Windows (PowerShell): 
tnc <NetWorker server> -port 5671

関連するDellの記事を参照してください。

受影響的產品

NetWorker

產品

Data Protection, NetWorker Family, NetWorker Series
文章屬性
文章編號: 000200132
文章類型: Solution
上次修改時間: 09 10月 2024
版本:  9
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。