PowerStore: dopo un aggiornamento a PowerStore 2.0.x.x o 2.1.x.x, i volumi non sono più accessibili agli host FC con collegamento diretto

摘要: Dopo un aggiornamento a PowerStore 2.0.x.x o 2.1.x.x, gli host con collegamento diretto che dispongono di driver compatibili con NVMe potrebbero perdere l'accesso a tutti i volumi.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Un host può perdere l'accesso ai volumi dopo l'aggiornamento di PowerStore alla versione interessata.
In alternativa, se PowerStore è stato precedentemente aggiornato alla versione interessata senza problemi, l'aggiornamento dei driver degli host a una versione che supporta NVMe espone questo problema.

原因

Dopo l'aggiornamento degli host per supportare NVMe, è possibile che si verifichi un secondo processo di accesso (PRLI) dall'host in seguito a ciascun evento di collegamento attivo. Questo secondo processo è destinato al trasporto NVMe e PowerStore non lo gestisce in modo ottimale.

解析度

Questo problema verrà risolto in una versione futura di PowerStoreOS.
Come soluzione alternativa, disabilitare il supporto NVMe nel driver.

 

Per gli host ESXi, consultare l'articolo della KB VMware 84325. Riepilogo di seguito.
 
ESXi con HBA QLogic o Marvel e driver qlnativefc:
esxcfg-module -s 'ql2xnvmesupport=0' qlnativefc
 
ESXi con HBA Emulex e driver lpfc:
esxcli system module parameters set -m lpfc -p lpfc_enable_fc4_type=1
 
 
Per gli host Red Hat, consultare l'articolo della KB 3522911. Riepilogo di seguito.
 
Host Linux con HBA QLogic o Marvel e driver qlnativefc - Aggiungere o modificare la riga seguente:
vi /etc/modprobe.d/qla2xxx.conf
ql2xnvmeenable=0
 
Host Linux con HBA Emulex e driver lpfc - Modificare il file seguente e aggiungere o modificare la riga riportata di seguito:
vi /etc/modprobe.d/lpfc.conf
 lpfc lpfc_enable_fc4_type=1

Gli host devono essere riavviati dopo aver modificato la configurazione del driver dell'HBA.

受影響的產品

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
文章屬性
文章編號: 000200588
文章類型: Solution
上次修改時間: 14 6月 2023
版本:  14
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。