VMware:由於磁碟整合-快照-問題,虛擬機器無法開啟電源
摘要: 本文說明如何解決由於磁碟整合或快照問題而導致虛擬機器 (VM) 無法開啟電源的情況。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
- 在儲存裝置中斷或快照移除後,VM 無法啟動電源。
- vCenter 顯示
Virtual Machine disk consolidation is needed警。 - 執行 磁碟整合 失敗,並顯示
Another task is in progress。
範例:
原因
當 filename-ctk.vmdk 檔案遺失。
錯誤記錄範例:

解析度
- 檢查 VM 的工作清單,收集 VMware ESXi 中工作的相關資訊。請參閱 Broadcom 文章 1013003收集 VMware ESXi 中工作的相關資訊
# vim-cmd vimsvc/task_list VMID
Kill過程
# lsof | grep vm-name # kill -9 process-id
- 全部移動
CTK檔案 放入暫存資料夾
# mkdir temp # mv *-ctk.vmdk
- 註解變更,全部追蹤檔案列
.vmdk,存在於.vmx
# less .vmx | grep .vmdk # vi .vmdk # :wq!
注意:插入 # 以在行中加上註解
CTK 如下。

- 建立以下副本
vmx檔,然後 對其進行編輯 以從 TRUE 更改為 FALSE
# cp vm-name.vmx vm-name.vmx.bck # vi vm-name.vmx scsix:x.ctkEnabled = "TRUE" ----> scsix:x.ctkEnabled = "False"
- 儲存檔案,然後重新載入
vmxfile
# vim-cmd vmsvc/reload VMID
請參閱 VMware 文章2009244錯誤:開啟虛擬機器電源時「無法開啟/建立變更追蹤檔案」
- 您現在應該可以成功開啟 VM 電源。整合工作正在進行中。
受影響的產品
VMware ESXi 6.x, VMware ESXi 7.x, VMware ESXi 8.x產品
Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX5016s, PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c
, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640
...
文章屬性
文章編號: 000209549
文章類型: Solution
上次修改時間: 17 11月 2025
版本: 6
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。