Dell Unity: Файли, створені з атрибутом «hidden» після оновлення Mac до версії 13 (macOS Ventura) (можна виправити користувачем)

摘要: Деякі типи файлів, що зберігаються у файлових системах Unity, можуть бути створені з атрибутом «прихований» після оновлення підключеного комп'ютера Mac до macOS Ventura (версія 13).

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

З моменту оновлення своїх клієнтів Mac до macOS Ventura (13.x) деякі новостворені файли створюються з набором атрибутів «прихований».

Наразі це здебільшого впливає на .doc та .pdf файли.

原因

Точна причина наразі невідома, але, схоже, це несумісність між Unity та macOS Ventura.

解析度

Виправити:
Наше тестування показує, що це проблема Apple.  Dell рекомендує постраждалим клієнтам відкривати запити на підтримку в Apple, щоб вони могли знати про масштаби проблеми та, можливо, визначити пріоритетність виправлення.

Спосіб вирішення:
Ми помітили, що поведінка, здається, не має місця, коли клієнт відключає лізинг каталогів SMB.  Тимчасово вимкніть оренду каталогів, щоб мінімізувати цю проблему.  

Для цього видайте таку команду в командному рядку Unity:
svc_nas ALL -param -f cifs -m smb2.capabilities -v 95
Щоб скасувати цю зміну, віддайте таку команду:
svc_nas ALL -param -f cifs -m smb2.capabilities -v 127

其他資訊

Є деякі повідомлення про те, що відключення лізингу каталогів не вирішує проблему для певних клієнтів.  Хоча ми ще не підтвердили це, другим альтернативним обхідним шляхом було б примусове використання діалекту max SMB до 2.1.  Для цього додайте наступне до файлу /etc/nsmb.conf на проблемному клієнті Mac:
[default]
protocol_vers_map=2
Крім того, ви можете видати таку команду на Unity, яка змусить усі з'єднання SMB на цьому сервері NAS домовлятися не вище SMB 2.1:
svc_nas [NAS_SERVER] -param -f cifs -modify smb2.maxDialect -v SMB2.1
Знову ж таки, цей параметр використовується для сервера NAS і набуває чинності відразу після повторного підключення до спільного ресурсу.

受影響的產品

Dell EMC Unity
文章屬性
文章編號: 000211582
文章類型: Solution
上次修改時間: 06 6月 2024
版本:  3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。