Windows Server:轉送器組態不正確,導致 Active Directory 網域中的 DNS 解析延遲或失敗

摘要: 如果在 Active Directory 域中的 DNS 伺服器上未正確配置轉發器,則名稱解析可能會失敗或花費比預期更長的時間。這通常只會影響外部 DNS 名稱的解析。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

外部 DNS 名稱解析完全失敗或花費比預期更長的時間。內部名稱解析可以毫無問題地運行,因為轉發器不用於內部解析。

原因

網域中 DNS 伺服器上的轉寄器組態不當可能會導致外部 DNS 解析延遲或失敗。具體而言, 不應將域中的 DNS 伺服器(幾乎始終是該域的域控制器 (DC))配置為相互轉發。只有域 的 DNS 伺服器才應用作轉發器。

貨運代理的良好候選者包括以下內容:

  • 知名的公共 DNS 伺服器,具有易於記憶的 IP 位址 (1.1.1.1, 8.8.8.8, 9.9.9.9, 等)
  • 您的網際網路服務提供商 (ISP) 提供的 DNS 伺服器

其他公共 DNS 伺服器也可能提供良好的回應。

也可以使用根提示而不是轉發器進行外部名稱解析。本文僅適用於正在使用轉發器的情況。

解析度

若要解決此問題,請執行下列程序:

  1. 在 DNS 伺服器上,啟動 DNS 管理員主控台。
  2. 在主控台的左窗格中,以滑鼠右鍵按一下伺服器,然後選取 內容。您可能需要在伺服器上按一下滑鼠左鍵,才能進行滑鼠右鍵按一下。
  3. 按一下 轉送程式 標籤,並檢閱轉送程式清單。
  4. 如果轉發器清單中有任何內部 DNS 伺服器,請按下 編輯 按鈕並從清單中刪除每個內部伺服器。提供所需的任何其他轉發器。
  5. 單擊 「確定 」關閉「編輯轉發器」視窗,然後再次關閉「屬性」 視窗。
  6. 在伺服器上按一下滑鼠右鍵,然後選取 清除快取。這對於準確評估外部名稱解析的回應時間是必要的。

在域中的所有 DNS 伺服器上重複上述步驟。轉發器基於每台伺服器進行配置,不會在伺服器之間複製。

執行這些步驟後,請使用 nslookup 命令來測試名稱解析並確認回應時間。

其他資訊

除了少數例外情況外,如果正確配置了 DNS,則域中的 DNS 伺服器在其區域中都具有相同的記錄。假設區域傳輸或 Active Directory 複寫功能正常,無論使用標準或 Active Directory 整合區域皆可正確運作,皆是如此。因此,如果一個 DNS 伺服器無法應答查詢,則域中的其他伺服器也無法這樣做。在這些伺服器之間轉發查詢只會減慢名稱解析過程。

受影響的產品

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

產品

PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450 , PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
文章屬性
文章編號: 000212612
文章類型: Solution
上次修改時間: 10 12月 2024
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。