Secure Connect Gateway — изменение учетных данных прокси-сервера HTTP не действует на шлюзах, модернизированных с SRS 3.52
摘要: В этой статье объясняется, почему изменение учетных данных прокси-сервера HTTP не действует на шлюзах, модернизированных с SRS 3.52.
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
Попытка изменить учетные данные прокси-сервера после перехода с SRS 3.52 на SCG 5.20 (который является единственным поддерживаемым путем миграции) приведет к потере соединения между шлюзом и Dell.
原因
Проблема возникает только в том случае, если учетные данные прокси-сервера обновляются после переноса SRS 3.x на SCG 5.20. Было замечено, что Mosquitto.service принимает пароль, настроенный в файле mosquito.conf, а не учетные данные, хранящиеся в защищенном хранилище. Было замечено, что обновленные учетные данные хранятся в защищенном хранилище, а файл mosquitto.conf не обновляется. Поскольку приоритетом для пароля является файл mosquito.conf, использовались старые учетные данные.
解析度
Обновите шлюз SCG с версии 5.20 до более поздней версии, которая удалит старые учетные данные из mosquitto.conf.
В противном случае, если шлюз должен оставаться на версии 5.20, выполните следующие действия.
В противном случае, если шлюз должен оставаться на версии 5.20, выполните следующие действия.
- Еще раз примените новые учетные данные из веб-интерфейса SCG во время его подключения.
- Подключитесь по SSH к SCG-VE и войдите в систему как root.
- Введите контейнер SRS с помощью
docker exec -it esrsde-app bash
- Закомментируйте пароль из mosquitto.conf с помощью следующей команды:
-
sed -i 's/proxy_password/#proxy_password/g' /etc/mosquitto/conf.d/mosquitto.conf
- Перезапустите службу Mosquitto:
wd stop esrsmosquitto wd start esrsmosquitto
- Выход из контейнера и сеанс SSH:
exit exit
- После выполнения указанных выше действий учетные данные будут изъяты из защищенного хранилища.
產品
Secure Connect Gateway, Secure Connect Gateway, Secure Connect Gateway - Virtual Edition文章屬性
文章編號: 000227392
文章類型: Solution
上次修改時間: 02 8月 2024
版本: 1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。