VxRail: vSphere Client reageert niet meer na het upgraden van vCenter Server 8.0 Update 3b

摘要: vSphere Client reageert niet meer na het upgraden van vCenter Server 8.0 Update 3b "U hebt geen rechten om dit object te bekijken of het is verwijderd"

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Dit probleem kan zich uiten in verschillende symptomen, die meestal optreden na een langere periode van inactiviteit van de sessie (1-2 uur)

  • Na het upgraden van vCenter Server naar 8.0.3.00200 wordt de vSphere Client instabiel en treden er sessietime-outs op.
  • De laadcirkelindicator draait voortdurend.
  • Het bladeren door de inventaris kan mislukken met fouten zoals "U hebt geen rechten om dit object te bekijken of het is verwijderd" als volgt:
    • Wanneer u zich probeert aan te melden bij de client, wordt de aanmeldingsknop mogelijk grijs weergegeven.
    • Authenticatie kan mislukken met de volgende fout: Er is een fout opgetreden bij het ophalen van identiteitsproviders

原因

Dit probleem is te wijten aan een wijziging in het standaardgedrag van RECYCLE_FACADES in Tomcat in de release. 

解析度

Dit probleem is opgelost in vCenter Server 8.0U 3c release - Link naar releaseopmerkingen 
 

U kunt dit probleem omzeilen door de onderstaande stappen uit te schakelen om RECYCLE_FACADES uit te schakelen.

  1. Meld u aan bij de vCenter Server met SSH
     
  2. Maak een back-up van het bestand catalina.properties.
     
    cp /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties /root/catalina.properties.bak

     
  3. Voer de volgende opdracht uit om een regel toe te voegen aan het einde van het oorspronkelijke bestand catalina.properties om RECYCLE_FACADES uit te schakelen.
     
    echo "org.apache.catalina.connector.RECYCLE_FACADES=false" >> /usr/lib/vmware-vsphere-ui/server/conf/catalina.properties

     
  4. Start de vsphere-ui-service opnieuw met de onderstaande opdracht.
     
    service-control --restart vsphere-ui

受影響的產品

Virtual Storage Integrator (VSI), VMware ESXi 8.x
文章屬性
文章編號: 000319177
文章類型: Solution
上次修改時間: 11 5月 2025
版本:  1
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。