2 Bronze

Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

After getting my Aurora  R7, I fired up task manager to monitor performance within the CPU, RAM etc. I noticed whilst at idle my RAM was using anything from 38 to 48% its capacity. I thought this is odd for 16GB of RAM. Surely windows cant be demanding that much memory for background applications. A little bit of process of elimination led me to the Killer Networks. I guess all Alienware have this. It turns out there was a bad memory leak with the Ethernet E2500. I uninstalled it and my idle RAM is now anything between 12-20% being used. I guess Dell have shipped these with bad drivers, so maybe its just as simple as updating the driver, but as I see no need for it, I got rid of it.

1 Solution

Accepted Solutions
3 Cadmium

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution
I had the same issue, try this it fixed it for me. Win 10 memory leak https://www.youtube.com/watch?v=7_yv-sZxub4

Mark
Minneapolis, Minnesota

Area 51 R2

Alienware 17 R3

Alienware - Area 51 R4

View solution in original post

0 Kudos
10 Replies
3 Argentum

Re: RAM showing high usage at idle?... Here's a tip

Jump to solution

I see the UWD driver now for my older system than yours. Its the latest, I installed it and found that Killer is moved to a windows'Apps'.  I got that too, and is cool. I use mine though for app controls. UWD wasn't the way when the Killer Networking drivers first came out .

0 Kudos
Moderator
Moderator

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

rockafella1,

 

I wonder if simply uninstalling the Killer Control Center application would have fixed the issue? Maybe other users can test this.

 

Before you uninstalled it, do you remember the version number of the Killer E2400/E2500 Gigabit Ethernet Controller driver?

 

The Aurora R7 website shows the latest as =
1.7.1042, A08, 9/10/18
XPS 8930, Aurora R7, Area-51 R3/R4/R5/R6

 

The Aurora R8 website shows the latest as =
1.7.1080, A10, 11/9/18
Aurora R8 only

 

 



 

0 Kudos
3 Argentum

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

  Excuse the accuracy, but I think 1.6 was the one I upgraded to, and had problems in Rivet techno with updates compatibility.. then a later vers of 1.6 did the trick with a custom uninstall'killer' app u can get at Killer website did the trick. mayB the very last 1.6xxx and 1.7 is when I see the uwd driver and uses the windows apppstore vers of Killer.  Its easy with the uninstall tool.

0 Kudos
3 Zinc

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

@DELL-Chris M wrote:

rockafella1,

 

I wonder if simply uninstalling the Killer Control Center application would have fixed the issue? Maybe other users can test this.

 

 


Nope.  Removing the KCC does nothing for the memory leak.  I have a similar issue with my R7.  I didn't think to look at the Killer ethernet drivers.  I'll give that a shot tonight.

0 Kudos
2 Bronze

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

Unfortunate I don't remember the driver version. I was too keen to get rid of Killer.

RAM been stable since. Very happy now that's gone 

0 Kudos
3 Zinc

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

@rockafella1 wrote:

After getting my Aurora  R7, I fired up task manager to monitor performance within the CPU, RAM etc. I noticed whilst at idle my RAM was using anything from 38 to 48% its capacity. I thought this is odd for 16GB of RAM. Surely windows cant be demanding that much memory for background applications. A little bit of process of elimination led me to the Killer Networks. I guess all Alienware have this. It turns out there was a bad memory leak with the Ethernet E2500. I uninstalled it and my idle RAM is now anything between 12-20% being used. I guess Dell have shipped these with bad drivers, so maybe its just as simple as updating the driver, but as I see no need for it, I got rid of it.


BTW, did you uninstall the drivers first then disable the NIC?  Disabling the E2500 adapter in my R7 does nothing as far as the memory leak is concerned due to the drivers still being loaded.  Uninstalling the adapter plus selecting delete drivers, then rebooting results in the adapter coming back but this time using the Microsoft provided driver.  It still did nothing for the excessive memory usage.

0 Kudos
3 Cadmium

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution
I had the same issue, try this it fixed it for me. Win 10 memory leak https://www.youtube.com/watch?v=7_yv-sZxub4

Mark
Minneapolis, Minnesota

Area 51 R2

Alienware 17 R3

Alienware - Area 51 R4

View solution in original post

0 Kudos
1 Copper

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

You are a lifesaver! thank you for sharing the answer to this ugly issue.

0 Kudos

Re: Aurora R7, high ram usage idle, disable Killer Ethernet

Jump to solution

I disabled (uninstalled) killer control center. And i have done what the video said. Its still 55 - 65% idle. I need help please!

0 Kudos