manos_xps_8300
1 Copper

XPS 8300 i7 2600 - Asus AMD RX 470 Strix 4GB

Hi,

I have a XPS 8300 with following specs:

Computer Model XPS 8300
BIOS Vendor Dell Inc.
BIOS Version A03
BIOS Date 2/15/2011
OS Version Microsoft Windows 10 Home

Processor

Manufacturer Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Clock Speed 3.4Ghz
L2 Cache Size 1024

Memory 8GB, PSU: 460W.

I also updated the BIOS to A06 (not sure why Dell still shows A03) today.

I installed the Asus AMD RX 470 Strix 4GB card and system does not even boot.

Is this card compatible with my system?

Thanks,

Manos

Tags (3)
0 Kudos
3 Replies

RE: XPS 8300 i7 2600 - Asus AMD RX 470 Strix 4GB

Hi Manos,


It is very much likely that the power supply is insufficient for the graphics card, have you tried booting the computer without the graphics card? does it post without the card

-

Aniketh S

Thanks & Regards,
Aniketh Sreenivasan
Social Media and Community Professional
Click here for : Order Status / Download Drivers

0 Kudos
manos_xps_8300
1 Copper

RE: XPS 8300 i7 2600 - Asus AMD RX 470 Strix 4GB

Hi Aniketh,

Thanks for speed reply.

Today I tried with a 500Watt PSU. Still the same, it did not boot. However, when I took out the 6pin power connector from the graphics card (it remained on the PCI slot), it looked like the system booted. I could hear the hdd working normally. Whereas before it was not spinning at all. Unfortunatelly, I don't have an extra graphics card so I could not confirm. What do you mean when you say "does it post without the card"? Also, what would be an appropriate PSU?

Thanks,

Manos

0 Kudos
Highlighted

RE: XPS 8300 i7 2600 - Asus AMD RX 470 Strix 4GB


Hi Manos,

Thank you for the update. 500 or 550 Watt PSU should be sufficient. Just check how many pin connector does the graphics card use, a 6pin or an 8pin. It would be best to use a 550 Watt PSU in case you upgrade any other hardware.

Thanks & Regards,
Aniketh Sreenivasan
Social Media and Community Professional
Click here for : Order Status / Download Drivers

0 Kudos