Highlighted
Informant
1 Copper

Beware of A07 BIOS on 6540 !!!

Do not update to A07 on 6540! It is a not fully tested bug containing BIOS! 
When I made a successful update from A05, my Windows 8.1 stopped booting anymore. After a short panic I got calm, and luckily having the old A05, I updated back to A05.

It is a shame that DELL released such a BIOS, without fully testing... 😞 
I just really hope that it will be remedted soon before a lot of 6540 user update it and cannot boot anymore. 

Tags (1)
10 Replies
theflash1932
6 Indium

RE: Beware of A07 BIOS on 6540 !!!

One failure doesn't constitute a "bug" ... it could have been an isolated issue with your system, download, or software.  I would actually encourage people to update it ... if it bricks the system, Dell will replace it under warranty, and then we will also know whether yours was a one-off occurrence or if it is an actual "bug" (sure, it's happened before, but it is very rare for Dell to release a buggy BIOS update).

0 Kudos
Informant
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

I could accept your reply. However I am also an IT worker. So before sending this message, I studied it a little bit.

Here are the facts.
The update processed as usual and the updater software confirmed that it was flawless. First I checked the BOIS (F2) and I've found no changes to the previous state. Great! The problem was not with BIOS booting, but with the Windows 8.1 booting. However I had another HDD with different W 8.1 so I changed/tested another HDD. but I got the same result. 
After that I got back to A05 BIOS and W 8.1 booted from both HDD without any problem. It proves definitely the problem of A07.

I can admit that this problem is maybe only in correlation with W 8.1 and does not occur when you use for example W 7, or other op sys. I can admit that it comes up only when any special configuration exist on the Windows.
However if the BIOS updater confirms a successful update and after that the client cannot boot his/her Windows, while coming back to an earlier BIOS and working without any problem... - even if it comes up only a few situation - I define it a bug! It is not the question how many users are involved. A normal end user follows the instruction and probably cannot manage to get back to an earlier BIOS on a not booting laptop.
So it is better to wait and not to risk.   

0 Kudos
Anthony001
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

My OS is 8.1 and I have the most current AMD and Intel drivers installed and functioning properly. I am now looking for an explanation as to why the newest BIOS A07 causes the AMD CCC and the 8790 driver to stop functioning. And in doing so an error message indicates the AMD driver has stopped and is incompatible. Additionally, the Intel graphics tray icon is removed and non-functional. The screen resolution is fixed at 1024x768? It was necessary for me to rollback to A05 to resume correct graphics. The system did not encounter the boot issue described by others. The graphics however, as previously described were not functioning properly. All aspects of the A07 flash did install properly. It does appear this may be isolated to a compatibility issue with A07 and Win 8.1 Any help is greatly appreciated...
0 Kudos

RE: Beware of A07 BIOS on 6540 !!!

I fried a motherboard on an Alienware updating to the "recommended" BIOS.  Dell replaced it under warranty, but the Dell Technician told me to never do Dell updates unless I am having an issue with the current driver or BIOS.  I had to pinch myself to avoid laughing out loud.  A few days later, the BIOS update was replaced on the Dell updates site.

0 Kudos
rcmcdonald91
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

I had the exact same problem... I was forced to reinstall Windows 8.1 and everything seems to be working again. I let Windows 8 install the AMD and Intel Graphics drivers that it wanted to (which I assume are the latest generics from AMD and Intel)

Actually, I just found some weird bugs with html5 video (youtube) and IE11. For some reason, if I play a full screen video (like Big Buck Bunny @ 108p), the video will cut in and out every 10-15 seconds or so. Likewise, when I un-fullscreen the video, I see a brief purple and green pixelated distortion on the screen as it transitions from fullscreen mode.

I just downgraded back to A05, problem went away...

0 Kudos
Informant
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

The AMD anyhow is the weak point of 6450. Even with the old BIOS I suffered a lot to get it work well. (install and river problems).

And I pretty guess that my case with A07 is similar and connected with graphics chip. Just you were more lucky than me as you could boot up to a windows screen. In my case the screen remained blank (black), also it seemed that laptop was booting. So in my case there was no chance to act on Windows level. I could solve it only very tricky way, pushing F12 getting to BIOS boot menu, interacting before Windows starts. A little bit hidden here you can find an option to update BIOS and if you have the old A05 on the HDD you can roll back. For me that was the only way to save the situation.

So I am rather sure that something wrong with A07. I hope it will be remedy soon....  

0 Kudos
buildpartner
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

I downloaded and installed the BIOS update A07 from A05 the other day and had no issues booting into my Dell built Ubuntu 12.04 on the Latitude E6540. However where it all fell apart was additionally installing the Dell Driver Pack A10 also released the other week.

Interestingly, Dell have now removed the A07 BIOS update form the support downloads section, so must seriously have identified an issue.

Even more interesting, in all this mess I have resolved Intel i7 Processor overheating and running slow at only 800MHz  issue, which is now running at correct 2.7G speed from processor model (with BIOS A07 and partially working Dell Driver A10). See related issues: http://en.community.dell.com/support-forums/laptop/f/3518/p/19523265/20504975.aspx#20504975 and a long thread covering many issues on slow CPU, overheating and discrete graphics issues here: http://forum.notebookreview.com/dell-latitude-vostro-precision/729032-e6540-owners-thread-3.html

I'll share some detail, in case it helps others as I still am awaiting resolution from Dell Pro Support and now have a barely usable system (though many issues resolved which I will detail) hopefully briefly:

Initial Issues with factory A05 BIOS and Ubuntu 12.04 updated to 12.04.4: Processor only running at 800MHz constantly running fan at high speed, Port Replicator with Dual monitor docking undocking, screen blank and resolution/mirroring reset, constantly running extremely hot @ 85 Degrees Celsius
------------------

STEPS TAKEN Before initial call to Dell:
Update to BIOS A05
Attempted install of Dell Driver Package A10 "E6440_E6540_A11.fish.tar.gz" would not run (auto install) would hang at bluetooth driver install

Advice from Dell Pro Support: Manually install deb packages from uncompressed Dell Driver Update file "E6440_E6540_A11.fish.tar.gz" without scripts

Steps taken with following issues:
1. approx 9:30 AM today: 1. installed new 3.11 kernel, typing following from kernel directory:
sudo dpkg -i linux-headers-3.11*.deb linux-image-3.11*.deb

2. installed main debs, typing following from /debs/main directory:
sudo dpkg -i *.deb

3. rebooted into 3.11, booted OK

4. installed remaining debs, typing following from /debs directory:
sudo dpkg -i *.deb

5. rebooted then hang booting to 3.11 on CUPS PRINTING/SPOOLER, when CTRL + ALT + DEL - terminated 143 STARTING SEND AN EVENT TO INDICATE PLYMOUTH IS UP [FAIL]
hang booting 3.11 recovery: 3.789591 ALPSPS/2, UDEVD TIMEOUT KILLING /sbin/crda [650]

NOTE: No "preseed", "fish" or "os-post" scripts run at all as advised to install manually by Dell
------------------

CURRENT (barely) WORKING SITUATION

Will only boot to kernel 3.5, Processor running at correct 2.7G speed, however system unstable as follows:
bootup takes logn time, hanging on certain drivers
oem-audio-hda-daily-lts-quantal-dkms system crash error
display running at 1920 x 1080 but showing low graphics (using default Intel driver, Radeon discrete not activated) - see screenshot

3.11 wont work in normal or Recovery
Result 3.11: Waiting Network configuration for over 2 minutes, Unity loads with no network, then hangs once enter any windows, screens including terminal, folder, System Profiler, etc. Can enter full terminal sessoins  from  CTRL + ALT + Function keys. No network at all in any session (terminal or unity)
Result 3.11 Recovery hangs on ALPSPS/2 driver
------------------

0 Kudos
Tooota
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

Today I have downloaded the " reccommended" BIOS update on my inspiron dell laptop, and since then my laptop does not boot. If this version of the BIOS is corrupted, they shouldn't  have reccommend it to their users or have even released it. i am not a techno savvy therefore i cannot resolve this on My own, also today is a holiday in egypt and hence i cannot reach technical dupport. I m so mad this is not the qualityof service i expect from dell:emotion-12:

Tags (1)
0 Kudos
buildpartner
1 Copper

RE: Beware of A07 BIOS on 6540 !!!

UPDATE: Still running on A07 BIOS, without crash in new built configuration as follows:

Full reinstall from Dell Recovery using latest (Jan 2014) release Dell Ubuntu 12.04 image, with latest Dell Driver Package. Running on all default drivers, with no third party drivers, therefore only on Intel graphics display, Radeon 8790M is not running. Very stable system.

Noted improvement on longer 2.7GHz performance of processor, though still defaults down to 800MHz after about 5 minutes or when running moderate grahpics (video). Seems to have same overheating issue as described in recent posts here:

forum.notebookreview.com/dell-latitude-vostro-precision/729032-e6540-owners-thread-43.html

Dell technician coming onsite tomorrow to test hardware. Will advise result.

Summary: A07 BIOS is unstable, unless using fresh install of Dell Ubuntu image and drivers. Dell have failed to provide an upgrade path for exisitng Dell Ubuntu customers, therefore rendering the A07 BIOS unusable unless you follow the steps I have outlined above.

0 Kudos