Jo-annB
1 Copper

Vostro 420 & Windows 7

I bought a Vostro 420 pre-installed with Vista Business in September.  All OK until I installed Windows 7 Professional using the Dell Upgrade kit.  To start with picture on the monitor did not occupy the entire widescreen, it was only 4:3 so I contacted Dell Hardware Warranty Support who resolved this issue - but gave me another one!  My previously quiet system now has a loud hum - I was a bit concerned about this so contacted the Support Chat again who suggested I start taking it to bits to isolate the problem.  I wasn't keen to do this so they suggested installing various drivers who may solve the problem and run a diagnostic Express Test which showed up three other problems.  Went back to Hardware Chat with the results of the test - and also another problem - my 19-in-1 Media Card Reader is now not available!  More drivers were installed by Dell - still now success and it also seems that the 19-in-1 Media Card Reader is not compatible with Windows 7!  I apparently have to wait till Dell writes a suitable driver to correct the problem.  Am I alone or does anyone else have these problems?  

0 Kudos
1 Reply
Highlighted
cornish_pasty
1 Copper

Re: Vostro 420 & Windows 7

You are not alone, I installed Windows 7 today on a Vostro 420, I too have the loud hummmmmm, and the video card is not recognised - installed all the latest video drivers without success... I'm stuck with a 640 x 480 resolution, when I need 1920 for work. I may have to resinstall Vista until Dell get their act together on this. All the best.

0 Kudos