SWUCRED
1 Copper

XPS 9560 with TB16 - Screen flicker

Jump to solution

I have the XPS 15 9560 with the i7-7700HQ and the 1080p screen.  The laptop works fine by itself and it works fine with a WD15 dock at my home with 1 montior.  At work I used the TB16 dock with the 240W adapter and I have 3 Dell U2414H monitors connected (DisplayPort, HDMI and Mini DisplayPort).  The Monitor connected via DisplayPort flickers at least a few times every minute.  The Monitor connected via Mini DisplayPort has flickered just a few times and the one connected via HDMI has never once flickered.  I have updated the bios to 1.1.3 and I have updated the Intel and the NVidia drivers.   I apologize in advance if this question has already been answered.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Mark141
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

I have the same laptop and have used both the WD15 and TB16 docks. I have the same problem. The only way I can resolve the issue is to use the advanced display settings and set my monitor to 30hz instead of 60hz. I don't have the issue with the WD15 but I use a 4K monitor and the WD15 only supports 4K at 30hz.

7 Replies
Highlighted
Mark141
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

I have the same laptop and have used both the WD15 and TB16 docks. I have the same problem. The only way I can resolve the issue is to use the advanced display settings and set my monitor to 30hz instead of 60hz. I don't have the issue with the WD15 but I use a 4K monitor and the WD15 only supports 4K at 30hz.

Zarpha
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

Thank you for this info.  In my Intel Graphics settings I didn't have an option for 30hz but I did for 50hz (originally on 59hz) and switching to 50hz has fixed my flicker issues.

0 Kudos
ryanworrell
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

Same issue here. Received my XPS 15 9560 and TB16 last week and I have screen flickering issues and occasional screen resets (goes black and then comes back) with three Dell U2414H displays daisy-chained via the TB16 using DP 1.2 compliant cables. All three monitors experience the flickering but the issues on each are independent of each other (not happening at the same time or in sync.)  I have not yet contacted Dell support but I am hoping since this appears to be a common issue a software fix will come soon.

0 Kudos
ryanworrell
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

Accidental double post...

0 Kudos
ryanworrell
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

When posting my previous response I had dropped my display settings from the default 59i Hz to 50i Hz and nearly resolved my flickering issue through my TB16 but now a week later I am getting flickering even at 50i Hz through the dock and can not go any lower (there is no option for 30 Hz). Dell seriously needs to address this issue. This is unacceptable for a $3000+ setup.

iconicTanget7
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

Hi: I too am having an issue with my screens flickering and going blank at times. Other times the screens will come back on but a few minutes later the flickering occurs again. Once in a while two screens will come back on and one will remain off.

This issue is becoming an annoyance, especially when I am working with multiple windows spread throughout the screens.

0 Kudos
ryanworrell
1 Copper

RE: XPS 9560 with TB16 - Screen flicker

Jump to solution

For what it's worth I spent about an hour with Dell Chat Support yesterday and after a remote session with them where the tech changed some drivers I have been running my three U2414H's at 60p Hz over a single DP chain with no flickering in the past 24 hours.

0 Kudos