Last reply by 09-17-2021 Solved
Start a Discussion
3 Argentum

WD19TB - 7490 - Dual 4k at 60hz - Impossible?

I picked up one of the new WD19TB Dell docks and hooked it up to a nearly-new 7490 with TB3. I tried every combination of HDMI and Diplayport (WD19TS has dual DP and HDMI, my monitors have both DP and HDMI) and cannot get this dock to talk to my 4k monitors at 60hz. They only go as high as 30hz.

I have a Caldigit TS3+ dock which hooks up to this same 7490 via TB3, and runs dual 4k at 60hz without a problem. I just can't get the new Dell WD19TB to do it. What am I doing wrong?

Replies (73)
3 Argentum

Quick edit to my post above, the user was able to connect dual 1440p @ 120hz @ 8bit color, using two DP 1.4 cables and his HB3 7420 and his WD19TBS dock. Quick and easy! No need for DP to USB-C and no need for any changes in the monitor's OSD. Thanks for the reminder @jphughan 

3 Argentum

@jphughan Yes, that is now my recollection as well. The trick was for me when I messed with it in March was to use both the DP ports on the WD19TB and ignore the USB-C and TB ports on the dock.

Out of the various cable combinations, that was the one I forgot to try during my limited time with the user on Monday. I'll give it another try next time I'm in the office, and should be able to manage 1440p @120hz for two monitors with a WD19TBS and a HBR3 7420.


7 Plutonium

@Mik68  The reason that cabling setup was necessary isn't because the downstream TB3 port supports DP 1.4.  The DP outputs and the USB-C output near the HDMI output can all support DP 1.4 as well, but actually NONE of them will support that when you're using an XPS 13 9380 anyway, because that system is only sending a DP 1.2 signal to the dock.  The reason that cabling setup was necessary is because the 9380 is a DP 1.2 system, and as such, when it's connected to a Thunderbolt 3 dock, it sends two DP 1.2 interfaces to the dock.  When the WD19TB(S) is paired with a DP 1.2 system, it allocates one of those interfaces to the downstream TB3 port, and the other interface is shared across all other ports.  A 4K 60 Hz display requires almost an entire DP 1.2 interface worth of bandwidth, so in your original setup, you were trying to have two 4K 60 Hz displays share a single DP 1.2 interface of bandwidth, leaving the entire second DP 1.2 interface completely unused.  That's why your second display didn't work properly.  By moving the second display to the downstream TB3 port, you've now got each display using its own DP 1.2 interface, and therefore each display having access to enough bandwidth to run properly.  This requirement is explained in the WD19TB(S) User Guide, for what it's worth.

@decker12  My memory from our discussions over PMs was that you were able to get dual 1440p 120 Hz running from an HBR3 system, but not dual 1440p 144 Hz.



I'm actually having that same problem with a brand new WD19TBS, a brand new 7420, and dual 1440p monitors. I can get one monitor to 144/120/100hz at 1440p and 8bit color, but the 2nd one only goes as high as 100hz at 6 bit color.

I think this is an HBR3 problem as @jphughan has mentioned before. I was only on site for a few minutes to try to figure it out so I need to dive a bit deeper, but I could have sworn I had dual 1440p's working on HBR3 laptops and WD19TB (not S) docks in the past.

2 Bronze
2 Bronze

I chime in late on this because this thread still ranked high as I was researching a similar, but not identical problem: trying to connect an XPS 9380 to two U2720Q monitors via a WD19TBS dock, the first monitor (connected via DisplayPort) would run at 4K 60 Hz, while the second (connected via USB-C, as DisplayPort on the monitor is in use for another PC) would not even run at 4K.

The solution in my case was to use USB-C port "7" (near the power connector), which features Thunderbolt 3, instead of USB-C port "3" (near the other display connectors), which features DisplayPort 1.4. The explanation is beyond me besides being unintuitive from a usability point of view, but now all three displays work fine at 4K (internal and two external monitors).


Did you try to reboot? We got it working, but only after rebooting. When unplugging/plugging while the laptop is running, one monitor will only come up with 30HZ. Only after rebooting, both work at 60Hz. No Idea what the underlying root cause is for this. 


@RedHagar  Yes, with that system and dual 4K displays, one of them needs to be on the downstream TB3 port, as you figured out. As for the other, did you try just using a regular HDMI cable to connect to the dock’s HDMI output? DP to HDMI adapters can be dicey because typical passive adapters rely on the source’s “Dual Mode DisplayPort” capability, which if supported by the source allows a DP output to send a native HDMI signal. But the question is what revision of HDMI is supported by the output. The fact that a DP output supports a given setup when operating in native DP mode does NOT guarantee that it supports an HDMI standard that supports the same setups. Sometimes for example a DP output that runs 4K 60 Hz might only support 1440p in HDMI mode. I’m not sure what the WD19TB’s capabilities are in that regard.


Update...after hours of fiddling, I now have both monitors running 4K @ 60Hz without buying another cable. I just moved the USB-C cable to the "expansion" USB-C port instead as per some of the notes on this forum. Then I used an HDMI to DP adapter to plug in my second HDMI-only monitor to the DP on the docking station. It worked, but caused some interference in my audio connection (clicking sounds). I moved the DP to the second port and then that stopped - and both monitors are running at 60 Hz.

So I got it all working...but only after hours of reading forums, testing cables and plugging things in dozens of times...not happy with Dell on this one. And this thread seems to be the only one that documents this whole issue - and solution. Dell support knows nothing about this.


I know this is an old thread but I'm just now adding a second 4K monitor to my 7490 docking station and having all the same problems and came across this thread. I just got the USB-C to DP cable and it immediately disabled the HDMI port, as it did for you. I was able to add an HDMI to DP adapter and plugged it into the full-size DP and the second monitor works...but they're both still at 30 Hz.

I guess I have to buy yet another cable for USB-C to HDMI as the second monitor only has HDMI anyway...I am so very unimpressed with Dell through all this! They pushed this docking station very hard for us when we first set this as a standard for our organization - and this is the first time we've tried to leverage that for 2 4K monitors...and find out that it doesn't work...or that we would have to buy all new sets of cables (for hundreds of docking stations). 

This is very disappointing - and will probably affect our purchasing decisions in the future.


Sadly, this only seems to work for some users? I've connected my two 4K60hz screens as shown in your picture, but still only getting 60hz on one display.

Dell XPS 17 with the NVIDIA GeForce GTX 1650 TI

Latest Solutions
Top Contributor