Linux General

Last reply by 11-29-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
2975

Aurora R10, BIOS 2.2.1 disabled IOMMU, need downgrade

I'm running Unraid on my system and after BIOS update (2.2.1) IOMMU has been disabled. This means that I'm no longer able to run VM on my second GPU. I know that IOMMU option was not visible in previous BIOS version but it was ON by default.
I downloaded the older version of the BIOS (2.1.3) but it doesn't allow me to downgrade. Is it possible to do it with USB stick and BIOS_IMG.rcv?

Solution (1)

Accepted Solutions
6 Indium
2446

No, there's no way to downgrade to a previous bios version once you are running 2.2.1.

 

View solution in original post

Replies (16)
6 Indium
2447

No, there's no way to downgrade to a previous bios version once you are running 2.2.1.

 

2 Bronze
2 Bronze
2340

I wouldn't consider this thread as "Solved", because latest BIOS update broke my whole setup and there is no way for me to fix it - Dell is software blocking the downgrade.
Since there are some Dell employees looking through this forum, maybe one of them can answer these questions:
1. Why the change log for the latest BIOS update doesn't mention anything about disabling IOMMU?
2. Will the next BIOS update have IOMMU enabled or (better) add the option to enable/disable IOMMU in BIOS.
3. Is buying new non Dell hardware the only option to fix my current problem?

2333

I can only answer #3. I am sure there's a fix in the works for the reported issues with this bios.

I would check the Dell driver download section from time to time, to see if a new bios update is available.

 

I do agree with you that a more detailed change log would be a welcome change.

 

All it lists is this:

Fixes:
- Fixed the issue where the BIOS cannot be updated using Dell SupportAssist.

 

It obviously contains a lot more than just that 1 update:

Dell Technologies highly recommends applying this important update as soon as possible. The update contains critical bug fixes and changes to improve functionality, reliability, and stability of your Dell system. It may also include security fixes and other feature enhancements.

 

Dell drivers page 

 

I agree 100%, they need to do a better job with the change log information so users have a better understanding of the effects of the update. If it would have said they disabled IOMMU, than I am sure you would have skipped this update.

2 Bronze
2 Bronze
2278

Please fix IOMMU

2154

Updating via support assist soft bricked my Aurora. Even the bit they listed was a fail

6 Indium
2145

Did you try the latest BIOS version for the R10?

2126

Yes, I updated the BIOS to version 2.2.2, but there is no change. IOMMU is still disabled:

iommu.jpg

2 Bronze
2 Bronze
1156

I am beyond disappointed with Dell for not including in the release notes that IOMMU would be disabled and it still is not fixed.  I have applied the most recent BIOS update from April 2022 with no change.  I purchased an R10 - first non-HP system in a long time.  I have multiple HP Desktops (much older) that have no issues with IOMMU or BIOS updates, release notes, etc.

For anyone at Dell that might be paying attention - even if there isn't a large # of people complaining about this, it is probably the most tech-savvy people that it affects and they are often asked about PC buying advice.  My advice will be to stick with others based on such an amateurish mistake. 

10 Diamond
1647

@sh run 

Since its for VM's (Virtual Machines) have you checked the other bios settings for VM? Other vendors UEFI BIOS, this feature is in "Advanced -> CPU configuration" and is called SVM (Secure Virtual Machine), or AMD-V or AMD Virtualization.

IOMMU is Intel's name for VT-x (virtual memory & execution) and VT-d (virtual PCIe addressing for peripherals).

Clearing cmos entirely then re setting may also change things.

There is zero linux support for the R10 Ryzen models or any other Dell model that did not ship with Linux.  Dell only supports the OS that shipped with the unit.

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support


Get Support on Twitter @DellCaresPro


Diagnostics & Tools

Latest Solutions
Top Contributor