alpivan
1 Copper

U2412M, No Signal from DVI-D, "Entering power save mode"

I have two Dell U2412M screens connected to my Nvidia GeForce GTX 570. For two years everything was working perfectly fine. Then today one of my screens just stopped displaying with a notification "Going to save mode" and "There's no signal coming from your computer"

The VGA port works just fine. Only the DVI-D seems to have the problem? I saw a lot of similar and same problems over the forum, but for the same problem I have. I have not seen any solution. What I want to know, is the DVI-D port gone and needs replacement? or is it something deeper in the monitors hardware. Or is there another way to fix it?

Kind Regards,
Ivan

Saw this unanswered post with a similar/same problem:

http://en.community.dell.com/support-forums/peripherals/f/3529/t/19406640

0 Kudos
4 Replies
Moderator
Moderator

RE: U2412M, No Signal from DVI-D, "Entering power save mode"

* Turn the computer off
* Turn both U2412M off
* Disconnect both U2412M from the Nvidia GeForce GTX 570
* Go to the non-working U2412M:
- Disconnect the power cable and the DVI cable from the rear/bottom of the U2412M
- Press the U2412M power button in for 10 seconds
* Connect the DVI-D cable to the U2412M and the other end to the Nvidia GeForce GTX 570
* Connect the power cable to the U2412M
* Do not connect the working U2412M!
* Turn the U2412M on, then the computer
* What appears on screen?

0 Kudos
alpivan
1 Copper

RE: U2412M, No Signal from DVI-D, "Entering power save mode"

Chris thank you for the fast reply. 

I've executed your instructions to the letter. 

and eachtime the result is the same. 

1. Dell logo appears on computer turn on.

2. Entering power save mode appears. 

0 Kudos
Moderator
Moderator

RE: U2412M, No Signal from DVI-D, "Entering power save mode"

* Test the DVI cable from the working monitor on the non-working monitor. If still no go, get the monitor exchanged
* Go back to the top of this Monitor Forum
* Open, "My 24" or smaller monitor does not have a Service Tag"

0 Kudos
alpivan
1 Copper

RE: U2412M, No Signal from DVI-D, "Entering power save mode"

Thanks again for the quick response. I've tried several cables. also tried to connect to several other computers with different cables. And the monitor still didn't work. 

Kind regards

Ivan

0 Kudos