LiamCA
1 Nickel

Dell PowerEdge M1000e - setting user logon domain

Jump to solution

So as the title states, I'm trying to work out how to configure a user logon domain, this can be (and has been) achieved on iDRACs using one of the following: 

racadm config -g cfgUserDomain -o cfgUserDomainName -i <index> <FQDN>
racadm set iDRAC.UserDomain.<index>.Name <FQDN>

However, neither of these work on our M1000e blade chassis:

$ racadm set iDRAC.UserDomain.1.Name <domain.domain>
ERROR: SWC0244 : Invalid Fully Qualified Device Descriptor (FQDD).
$ racadm config -g cfgUserDomain -o cfgUserDomainName -i 1 <domain.domain>
ERROR: Invalid group name specified.

Is there a separate command for blade chassis? I'm able to logon with user@domain.domain but I'd like to add our logon domain to the web GUI drop down menu. 

Additionally, as anyone answering may have already been down this rabbit hole, is there a way to set the default logon domain for iDRACs/CMCs? On the iDRACs I've added the logon domain to, I still have to select our domain from the drop down menu, default being "This iDRAC".

Thanks in advance

 

0 Kudos
2 Solutions

Accepted Solutions

Re: Dell PowerEdge M1000e - setting user logon domain

Jump to solution

I looked at the Command Reference guides for firmware version 6.20, which should be the current revision. Neither of the commands you have listed are included in the guide. You might give cfgDNSDomainName a look, though. I'll link to the CLI guide.

https://topics-cdn.dell.com/pdf/dell-chassis-management-controller-v620-poweredge-m1000e_cli-guide_e...

Page 95.

That having been said, I'm also seeing cfgADRootDomain and cfgADRacDomain. I'm going to try to reach one of my systems management resources to get some further clarification for us.

#Iwork4Dell
LiamCA
1 Nickel

Re: Dell PowerEdge M1000e - setting user logon domain

Jump to solution

To clarify, the winning command here was:

racadm config -g cfgActiveDirectory -o cfgADRacDomain <domain.name> 

Thanks for the help, works a treat 🙂 

4 Replies

Re: Dell PowerEdge M1000e - setting user logon domain

Jump to solution

Before we begin, could you share the firmware version the CMC is running? 

#Iwork4Dell
0 Kudos
Highlighted
LiamCA
1 Nickel

Re: Dell PowerEdge M1000e - setting user logon domain

Jump to solution
Hi, not sure what happened to my previous reply - maybe it didn't like all the numbers from the version? Anyway, we're running the latest version of CMC on both active and passive.
0 Kudos

Re: Dell PowerEdge M1000e - setting user logon domain

Jump to solution

I looked at the Command Reference guides for firmware version 6.20, which should be the current revision. Neither of the commands you have listed are included in the guide. You might give cfgDNSDomainName a look, though. I'll link to the CLI guide.

https://topics-cdn.dell.com/pdf/dell-chassis-management-controller-v620-poweredge-m1000e_cli-guide_e...

Page 95.

That having been said, I'm also seeing cfgADRootDomain and cfgADRacDomain. I'm going to try to reach one of my systems management resources to get some further clarification for us.

#Iwork4Dell
LiamCA
1 Nickel

Re: Dell PowerEdge M1000e - setting user logon domain

Jump to solution

To clarify, the winning command here was:

racadm config -g cfgActiveDirectory -o cfgADRacDomain <domain.name> 

Thanks for the help, works a treat 🙂