Precision Fixed Workstations

Last reply by 04-10-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell Precision T5500 Bios Update failed A17 -> A18

After executing the bios update file, Windows 10 displays the following messages during the reboot:

1. Bios update failed!

2.Embedded Microcontroller Firmware Update Successful

3. Could not find the firmware image in memory.

Replies (9)

I have been having the EXACT SAME issue with no resolution yet. I am baffled. I can’t upgrade to A17 or A18. Did CMOS reset, removed alll peripherals . Have you had any success?

I have the exact same issue.

I have replaced the CMOS battery.

Cleared the CMOS.

Removed PCI cards except video.

Still no Luck!

I am able to flash the BIOS all the way back to A12 and back to A16.

But after that, no luck.

I get a bad checksum error!

I have been experiencing same issue and it is pushing me to the edge. (I have not jumped yet). Have you met with any success?

I've seen a case where a Dell BIOS update only worked on certain versions of Windows - this was with an older machine that was originally released with Vista or Windows 7.  Rolling back from Windows 10 to an earlier version (Vista or Windows 7) was required to successfully run the BIOS update from Windows.  I suspect the same thing might be occurring here.

I make it a point to never update the BIOS from Windows to reduce the chance of bricking the machine.

I'd do the BIOS update from a USB stick.  Dell's how to update the BIOS article here.  If I can, I update via the F12 method, but I don't think this is available when the T5500 was released.  BIOS can also be updated by using Dell's tools to create a bootable USB stick - see following section in link above:

        7. How to Update Your System BIOS Using a USB Flash Drive

Or, if you want to update BIOS via bootable FreeDOS (or do everything from Linux) you can follow links under:

        8. Updating the Dell BIOS in Linux and Ubuntu Environments

                Quick link to FreeDOS method here.

                See "3. Creating a USB Bootable Storage Device Using FreeDOS (Legacy Sytems)"

The other machine I mentioned whose BIOS wouldn't update on Windows 10 was a Dell Precision 1500 here.  If you follow the links, seems FreeDOS didn't work either, had to roll back to Windows 7 to do BIOS update.

I suspect in both cases that option 7 above using Dell's tools to create a bootable USB stick might work, rather than using FreeDOS.

I've been getting this same problem as well, for both A17 and A18. Like others, any earlier firmware A16 or below flashes successfully, but the latest ones that purport to address the microcode security issues fail.

The exe update from both Windows 7 and Windows 10 gives a green checkmark, but on reboot it just garbles the screen and then reverts to A16 without performing the BIOS update.

Creating bootable flash drives to flash the .bin files, or using the dell diagnostic and the .exe, both fail. Errors out saying that the BIOS image failed consistency checks. I've verified repeatedly that the checksums match those on Dell's website. This is for both A17 and A18

I also contacted Dell at one point trying to get assistance for this error, and the only solution they could come up was to try downloading the file again later. They kept telling me this over and over again, every time I contacted them, even after I kept explaining to them that there was a problem with the BIOS packages for A17 and A18. I think they just don't care if your machine isn't under an active warranty.

I came across this blog page: https://deploymentramblings.wordpress.com/2012/06/06/updating-dell-bios-with-powershell-updated/ and tried that, but couldn't get it to work properly.

I like Dell Workstations. They're reliable and good value, but this is pretty frustrating and Dell's been no help whatsoever in resolving this. This kind of mirrors my experience more generally with Dell support. Their products are good, but whenever you have hardware issues, dealing with them is often as or more frustrating than the problem itself.

After many years dealing with them, the process is usually:
1- Go through extensive troubleshooting on your own to make sure the problem is really something hardware related
2- Call / chat with Dell support and spend an hour or more explaining the problem and convincing them that it's the problem that you already diagnosed, while they try to convince you it's something software / configuration related.
3- If you're under warranty, they replace or repair the product (depending on whether it's a peripheral or a computer), although it frequently takes a while since they tend to replace peripherals with refurbished peripherals (just with different problems than the one you were having), and with computers, you may be waiting over a month for parts / repair (and they may or may not actually fix the problem).
4- If you're not under warranty, their only interest is generally trying to sell you warranty services to even consider your problem.

I've also built computers, and for the most part, I've found that with most parts manufacturers, you just put through a warranty claim, or send them an email and you're done. I don't understand why Dell has to make things so difficult.

Anyway, getting back from my frustrated tangent, this seems to be a problem either with the BIOS files for A17 / A18 on Dell's website, or else how they've packaged them. When all the earlier BIOS updated flash successfully, repeatedly, it's pretty clear the NVRAM is fine. The A17 / A18 BIOS update packages on Dell's server are just corrupt, and since most T5500 machines haven't been under warranty for ages, they don't seem to be very (if at all) interested in addressing this.

I'd love to be proven wrong.

Hello,

Sorry i have to disagree with the statement you made about Dell Servers and accessing the A18 BIOS update for the Dell Precision T5500 series. Having several of these units in operation for multiple years now, Only had 2 units out of 40 have an issue updating the BIOS to the newest version. If you have the right BIOS update downloaded directly from Dell's website (and not a third party site) then you should have the latest and up-to-date version that should run basically error-free. The two units that did not load correctly had issues that were correctable after proper investigation and low cost fixes. Good Luck!!! 

JediMaster2020,

Did you even look at the link I shared. Do you seriously think that I would go to those lengths indicated in said link before verifying I downloaded the right BIOS files from Dell's website, triple checking the checksums, trying many numerous ways to finesse the machine into accepting the BIOS update? And after everything, literally nothing works, and from what I've been able to find, it's a problem with how Dell compiled / configured the BIOS installer.

If you have a legitimate fix for this, please post it. Otherwise, your post comes across simply as borderline trolling. 

It's wonderful that you (allegedly) have 40 of these machines and only 2 with the problem. Some of us don't have that luxury, and so far the only response I ever got from Dell support was "oh try it in a couple days" about twenty times to put me off every time I contacted them.

The only viable solution I see at this point is selling the machine and building a new one myself. If you have an actual solution, please share your supposed low cost fixes instead of chest-beating about how rich you are and how easy this problem is for you to fix.

I kind of doubt you will, given that you have only one post, and you appear to have only registered to troll this thread.

I gave up and going to take it apart and sell it for parts for whatever its worth. Ended up building my own PC.

Top Contributor
Latest Solutions