Precision Mobile Workstations

Last reply by 05-24-2019 Solved
Start a Discussion
2 Bronze
2 Bronze
1066

Precision 5520 BIOS update missing from LVFS

I run Fedora 30 and would like to update my BIOS. The most recent version available on the Dell support website is 1.13.0, but the most recent version available on LVFS (which seems to be the official way to upgrade the BIOS on Linux systems) is 1.12.1. To any Dell employees on the forums, will the most recent BIOS update be uploaded to LVFS for Linux users? I tried making a bootable FreeDOS image to install the update and it's prohibitively difficult since FreeDOS doesn't provide any live images, only installation images.

Replies (2)
923

Thanks, this is exactly what I needed. I eventually figured out how to create a bootable FreeDOS image (http://www.supermaru.com/2015/01/creating-bootable-dos-image-linux/) but these directions got me up and running much more quickly.

Unfortunately it seems like BIOS updates are the only ones that are able to be applied via a bootable DOS image; I tried running the TB16 dock firmware update utility and the Intel Thunderbolt firmware update utility from a bootable DOS image and both gave an error saying they don't work in DOS mode.

Moderator
Moderator
1003

@lx522,

I will check to see if/when the BIOS will be loaded to LVFS.

As a work around for now:

1. copy the BIOS update to a USB key

2. boot to the one time boot menu using F12 and search for the BIOS update option in the list

3. Hit enter on that option and an interface will load

4. explore to the location of the BIOS update and run

Justin C Dell Technical Support | Project Sputnik


Dell Support is also on Twitter! https://twitter.com/DellCaresPRO


Latest Solutions
Top Contributor