Precision Mobile Workstations

Last reply by 12-08-2020 Solved
Start a Discussion
2 Bronze
2 Bronze
17271

Precision 7540 will only boot Linux if charger is connected

I recently got a new Precision 7540 laptop for work. The first thing I did was wipe the SSD and install the latest Linux Mint. It runs great, with one caveat. It will only boot if the AC adapter is plugged in. On battery, 9 times out of 10, it won't cold boot. I see the Dell splash screen come and go. I see a message about booting in insecure mode because secure boot is disabled, and that's it. I never get prompted for my disk decryption key, although the keyboard backlight activates if I touch the keyboard. I have to poweroff by holding the power button to get out of this state. If I plug the charger back in and power on again, it comes right back up. Once I've made it to the login screen, I can unplug the charger and everything keeps working normally from there. I've reinstalled without full disk encryption and it doesn't seem to make a difference. I've tried the latest Ubuntu, Kubuntu, Fedora, as well as Ubuntu 18.04.3, all with the same startup issue. The issue is there before I install Nvidia drivers and afterwards, so that seems to have no effect. Ubuntu 18.04 seems to get farther; I actually see the Ubuntu logo with the 5 white dots that turn orange, and then back to white, and then back to orange... for 20 minutes until I hold down the power button, plug in the charger, and power on again. And then it comes right back up!

I spoke with Dell technical support and their stance was that since the laptop shipped with Windows, they can't provide support. So I reinstalled Windows 10, and frustratingly, the problem isn't there. I was hoping it was an obvious hardware problem that could be repaired.

I know Dell ships this model with Ubuntu 18.04 installed, so I know the hardware 'should' be able to work in that configuration. However, Dell has their own customized Ubuntu image. Because my system shipped with Windows, I don't have access to an official Dell Ubuntu image that would likely contain any needed patches/fixes, if the issue truly is limited to software.

My main concern is that I'm coming up on 30 days with this laptop. If I can't gain confidence that it's going to work in the long term, I'd rather send it back and eat the cost of restocking rather than risk being stuck with a laptop that's not fit for purpose. Is anyone out there running a stock (non Dell customized) version of the latest Ubuntu on the Precision 7540? If so, do you see this same issue?

Replies (47)
12993

Quick update, bios reverted to 1.10.1 and issue disappeared, bios updated again an issues pops out.

Adding kernel parameters solves the issue. Posting solution:

in /etc/default/grub add dis_ucode_ldr in this way

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"

then

sudo update-grub

12938

dis_ucode_ldr fixes the problem for me as well.  Glad Dell is looking into this... it's ridiculous!

12885

Thank you a lot for your message, it solved my problem:

- Dell 7530, Ubuntu 19.10

- after bios update, loading Ubuntu failed just after second line "Loading initial ramdisk", even in recovery mode

- adding dis_ucode_ldr in grub solves this problem.

 

Just a question: do we lose functionality by adding this option?

 

Best,

12472

I have the same problem with a pre installed ubuntu 18.04 on my precision 3530. Could you tell me how you added that command in GRUB since it is a read only file?

21995

You have to do it with root privileges. For example, from terminal

sudo gedit /etc/default/grub

12455

I did this and it fixed the startup without power issue. Thank you very much. 

12223

This does not work for a Dell Precision 7730 with a nvidia P3200 when using "discrete only" graphics as enabled in the bios. If I change to "switchable" graphics I can boot using no power only if I have enabled "intel" with "sudo prime-select intel". If I enable "nvidia" with prime I cannot boot. I am running the latest ubuntu kernel with nvidia 435.21 driver as reported by "nvidia-smi". This laptop is essentially a desktop without the ability to power on from battery.

11955

I had the same problem with my Precision 7730 and the above "grub fix" solved it.

2 Bronze
2 Bronze
4011

I had the same problem with my Latitude 5500 - Fedora installed. Problem was fixed via editing grub config like above

11399

It's great that there is a workaround for this problem, but it's been months without a real fix.  Is Dell going to fix this, or does it only support booting laptops when they are plugged in?

Latest Solutions
Top Contributor