Precision Mobile Workstations

Last reply by 12-08-2020 Solved
Start a Discussion
2 Bronze
2 Bronze

Precision 7540 will only boot Linux if charger is connected

I recently got a new Precision 7540 laptop for work. The first thing I did was wipe the SSD and install the latest Linux Mint. It runs great, with one caveat. It will only boot if the AC adapter is plugged in. On battery, 9 times out of 10, it won't cold boot. I see the Dell splash screen come and go. I see a message about booting in insecure mode because secure boot is disabled, and that's it. I never get prompted for my disk decryption key, although the keyboard backlight activates if I touch the keyboard. I have to poweroff by holding the power button to get out of this state. If I plug the charger back in and power on again, it comes right back up. Once I've made it to the login screen, I can unplug the charger and everything keeps working normally from there. I've reinstalled without full disk encryption and it doesn't seem to make a difference. I've tried the latest Ubuntu, Kubuntu, Fedora, as well as Ubuntu 18.04.3, all with the same startup issue. The issue is there before I install Nvidia drivers and afterwards, so that seems to have no effect. Ubuntu 18.04 seems to get farther; I actually see the Ubuntu logo with the 5 white dots that turn orange, and then back to white, and then back to orange... for 20 minutes until I hold down the power button, plug in the charger, and power on again. And then it comes right back up!

I spoke with Dell technical support and their stance was that since the laptop shipped with Windows, they can't provide support. So I reinstalled Windows 10, and frustratingly, the problem isn't there. I was hoping it was an obvious hardware problem that could be repaired.

I know Dell ships this model with Ubuntu 18.04 installed, so I know the hardware 'should' be able to work in that configuration. However, Dell has their own customized Ubuntu image. Because my system shipped with Windows, I don't have access to an official Dell Ubuntu image that would likely contain any needed patches/fixes, if the issue truly is limited to software.

My main concern is that I'm coming up on 30 days with this laptop. If I can't gain confidence that it's going to work in the long term, I'd rather send it back and eat the cost of restocking rather than risk being stuck with a laptop that's not fit for purpose. Is anyone out there running a stock (non Dell customized) version of the latest Ubuntu on the Precision 7540? If so, do you see this same issue?

Replies (47)
2 Bronze
2 Bronze

last time updated bios firmware

Vendor: Dell Inc.
Version: 1.10.2

alse solved the problem on my p7740

It seems as with the most recent BIOS Revision 1.14.4 (13 Nov 2020) in combination with most recent intel-microcode package version 3.20201110.0ubuntu0.18.04.2, the issue is resolved: system boots fine, no workarounds or package downgrades necessary anymore. 

 

Update: I restored the original settings leaving just "quiet splash" and it seems to work, for the moment.

2 Bronze
2 Bronze

I've been facing the same problem with Ubuntu Mate 20.04 recently and after a couple of days and countless attempts to find the solution (adding dis_ucode_ldr in grub did not help) finally discovered a simple one that has worked for me.
Try editing grub adding the "nomodeset" option in the line "GRUB_CMDLINE_LINUX_DEFAULT" (if present),
so that it reads as follows:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset".
Hope that might help someone as well.

More details on nomodeset here: https://askubuntu.com/questions/207175/what-does-nomodeset-do

Instead of forcing 'dis_ucode_ldr', a slightly better workaround would be to force the intel-microcode package back to a known-good version; 3.20191115.1ubuntu0.18.04.2 in my case.  That way, at least those microcode updates can be applied.  Then, 'apt-mark hold intel-microcode' until we've got a proper solution.

 

2 Bronze
2 Bronze

I've logged in to state that I also have noticed this problem booting current Ubuntu 18.04 (with intel-microcode 3.20200609.0ubuntu0.18.04.1) on a Dell Precision 7530, with current BIOS Revision 1.13.1 (09 Jun 2020).  I'm also confirming the 'dis_ucode_ldr' workaround -- but this is not a proper solution, of course.

Thanks for the tip about fwupd (gnome-firmware); this tool made BIOS v1.7.0 available again. After downgrading to v1.7.0 and then upgrading back to v1.9.0, everything is working again. Not sure if it was changing the BIOS, or some other update that got things back on track.

 

Dale

I did this but the problem is still there

I have already removed "quiet splash" from GRUB_CMDLINE_LINUX_DEFAULT so that I can see all the commands when rebooting, but not much help.

What's the best way of troubleshooting this?

It works perfectly on my Latitude 5491. Thanks a lot @reallucamosca I owe you a beer.

Hi @dalekuhn ,

I agree wholeheartedly that disabling microcode updates is a band-aid and not a solution.

By the way, fwupdmgr works well for me on this laptop for updating firmware.  No windows required.

I would also like a high end AMD workstation, but not sure I'll be getting a Dell again based on their (lack of) support for this laptop.

Ed

Top Contributor
Latest Solutions