Secure Connect Gateway

Last reply by 11-18-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
13086

Reset admin password

I've installed and configured the Secure Connect Gateway.

At the initial configuration I had to setup a password for the admin account for the webinterface. I generated one and it was accepted. After that I completed the configueration and adding devices.

But now, when I try to login, I get an error "We can't continue with this password. Make sure your password doesn't have any invalid characters, then try again."

I don't know what characters are invalid, but it has some special characters in it. Although, these were not identified as invalid when setting up the password.

Can someone tell me how to reset the admin password? I'm able to login with root on the console, but not in the webinterface anymore. That only worked on the initial setup page.

Solution (1)

Accepted Solutions
10860

Hi again,

 

I have been doing research on this topic since yesterday. As of now, SCG support only the below special characters in the password,

 

~

@

*

=

+

#

$

%

^

&

(

)

-

_

[

]

{

}

.

 

Please do not use exclamation mark ( ! ) in the admin password for Secure Connect Gateway Policy Manager 5.00.00.10 . If you use an exclamation mark, password change will most possibly fail.

 

For reset the admin password , please follow the below steps .

 

1. Login to the SCG Appliance system through SSH using root credentials (rootUserName and rootPassword )

 

2. After the successful login, Run the below curl command,

curl -k -L -i -s -X --header "Content-Type: application/json" --request PUT --data {"rootUserName":"root","rootPassword":"xxxx","newAdminPassword" :"xxxxxxxx","confirmAdminPassword":"xxxxxxx"}' 'https://10.x.x.x:5700/SupportAssist/api/v2/adminPassword/reset'

Copy the above command and replace the values bold italic.
Please note that do not use previously used passwords as new admin passwords.

 

3. After executing the above command, login to SCG appliance using web UI with new admin credentials

 

Hope this will help!

 

Thanks,

Erman Özkurt
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!

View solution in original post

Replies (20)
11001

A.T_,

 

 

Would you confirm a couple things for me, so we know the steps given are correct?

 

It seems like a fresh install, but would confirm if it is, or is an uppgrade?

 

What version number of  Secure Connect Gateway are you using?

 

What version are you using, the application or the appliance? I ask as the authentication for both is different.

 

 

Let me know.

 

 


Chris Hawk
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
10960

Chris,

This is a fresh install of the appliance version.

I downloaded the most recent version on that day. Can't login, so can't check the version anywhere.
The downloaded file is "Secureconnectgateway_VE.x86_64-5.0000.10_ovf.tar"

Regards,

André.

10949

A.T_,

It sounds like something may have got corrupted in the install, if you redeploy and it does it again then let me know.

 

 


Chris Hawk
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
10923

So there is no way to reset the password of the webinterface if I am able to login on the console with the root account?

If you can tell me what characters aren't allowed, I can see if they are present in the password and we know if something went corrupted of the password is the problem.

Completely reinstalling and configuring it again takes a couple of hours. That's not the "solution" I prefer.

10908

Hello,
Unfortunately, I couldn't find any information about which characters are allowed. Currently, there is no way to reset the admin password from the web interface. When I review this article on page 20 https://dell.to/3CPWU8M you should have SCGAdmins privileges to Create, edit, or delete a credential account. But you want to reset the admin password, I couldn't find a way to do this without redeploying.


Thanks,

Erman Özkurt
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
10902

Hello,
The link is for the application edition. As I mentioned in my first response we're using the APPLIANCE version.
I understand it's not possible through the webinterface. I can't even login there. That why I'm asking if there is an option outside this, through the (Linux) console with the root account.

10861

Hi again,

 

I have been doing research on this topic since yesterday. As of now, SCG support only the below special characters in the password,

 

~

@

*

=

+

#

$

%

^

&

(

)

-

_

[

]

{

}

.

 

Please do not use exclamation mark ( ! ) in the admin password for Secure Connect Gateway Policy Manager 5.00.00.10 . If you use an exclamation mark, password change will most possibly fail.

 

For reset the admin password , please follow the below steps .

 

1. Login to the SCG Appliance system through SSH using root credentials (rootUserName and rootPassword )

 

2. After the successful login, Run the below curl command,

curl -k -L -i -s -X --header "Content-Type: application/json" --request PUT --data {"rootUserName":"root","rootPassword":"xxxx","newAdminPassword" :"xxxxxxxx","confirmAdminPassword":"xxxxxxx"}' 'https://10.x.x.x:5700/SupportAssist/api/v2/adminPassword/reset'

Copy the above command and replace the values bold italic.
Please note that do not use previously used passwords as new admin passwords.

 

3. After executing the above command, login to SCG appliance using web UI with new admin credentials

 

Hope this will help!

 

Thanks,

Erman Özkurt
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
10797

Hello Erman,

First of all I don't see any yellow highlights, but I think I have to replace xxxx and the IP-address.

When I do this nothing happens. All I get is a >

It looks like the command isn't complete, as I see three single quotes. Two before the URL with a space between them and one after it. 
If I place an extra one before the { something happens, but it give errors back.

SCG_password_reset_error.png

EDIT: I see I missed a double quote before newAdminPassword, but even after adding that I get the same error.

10801

Hi, I edited again those parts as bold italic because the highlights weren't out. and I'm attaching a screenshot so it can help. Can you try again as below screenshot? Image


Thanks,

Erman Özkurt
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
Latest Solutions
Top Contributor