Storage, Drives & Media

Last reply by 09-08-2020 Unsolved
Start a Discussion
1 Amber
1 Amber

Dell Docking Station/Lenovo Laptop Monitor Issue



I have a Dell Dock Model # K17A/K17A001 that I purchased for work purposes with a Dell laptop and worked great. Employer pulled Dell laptop and I'm using personal laptop and the monitors are not working thru Dock. Ethernet, mouse and keyboard still work but any idea on how to get monitors to work?

Laptop is Lenovo Ideapad 330 Windows 10. 

The USB-C doesn't charge the laptop which I can live with but really need monitors to work. 


Thanks in advance!



Replies (7)
2 Bronze
2 Bronze

I have the same problem. Did you manage to find a solution for your issue? 



2 Bronze
2 Bronze

Same problem. Happens every time I switch from hardwired/on-the-dock to wireless (off to a meeting). When I return the HMI devices switch over fine, the network switches from wifi to wired -- but the external monitors are MIA, never to return. If I tell Win10 to go and look for additional displays in does NOT find them.

Workaround for Win10 (usually works)

  1. Shutdown (not restart!) the laptop
  2. Unplug then reconnect the docking station (science or superstition?)
  3. Reboot the laptop using the laptop screen
  4. After a short pause the laptop "rediscovers" the external monitors. They come to life,with all the settings I used last.(Which means the info was retained correctly by Win10.) 
  5. Close the lid and get back to work. 
  6. Until the next meeting, then lather rinse repeat


  • Not a power issue. Fully rated PS plugged into both Lenovo laptop and dock.
  • Not a video power issue. All monitors work fine once they work at all.
  • Always possible that there might be a "power saving when lid closed" option that is misbehaving. But "never" seems rather definitive.



This seems super obvious but I didn't try it and have spent 3 weeks only having 2 screens instead of all 3 - and the screen in the middle was the one not working, so that was annoying. I did this and got them working, so thanks for this very simple fix. 


this didn't work for me any other ideas?



Thanks for the tutorial tutorial, love, tutorial and tutorial

2 Bronze
2 Bronze

I'm still having this issue, did you ever get a work around?


Never worked for me either, did you ever find an alternative? 

Latest Solutions
Top Contributor