grimm00s
1 Copper

PasswordServer does not work anymore

Dear all,

 

in the past we use this ini config for login on Wyse client:

SignOn=Yes LastUsername=yes SaveLastDomainUser=Yes
DisableDomain=yes
DomainList="HQ" Disable=yes
PasswordServer=10.235.10.51;10.235.10.52 Connect=RDP

Since today we have problem, that password server does not work anymore. For example 3020 modell with firmaware 8.5_017 a user with expired password logon and instead of PasswordServer opens via RDP they get popup-window on ThinOS that password expired and ask for new password + confirm password but this does not work also.

Does PasswordServer command in wnos.ini files does not work with latest firmware?

0 Kudos
6 Replies

Re: PasswordServer does not work anymore

You dont say whether you are using a Citrix broker or a MS broker.

Try dropping the second sign on server.  It is not clear if that parameter supports multiples

PasswordServer=10.235.10.51 AccountSelfService=yes Connect=RDP

 


If AccountSelfService=yes follows PasswordServer, click the icon
on the signon window to do account self-service.

 

0 Kudos
grimm00s
1 Copper

Re: PasswordServer does not work anymore

This is the complete config and this was working all the time. Now after upgrade firmware the part of the passwordserver in case of expired password does not work anymore. The time before if a password expired and user try to login with old password an RDP session to one of the passwordserver etablish and on these machine they can change their domain password. We don´t use AccountSelfService on our Citrix farm.


;*************************************************************
;*                                                           *
;*         This wnos.ini file was generated with the         *
;*              Configuration Generator 8.2.01               *
;*              Copyright by Thomas Moellerbernd             *
;*                                                           *
;*                https://www.technicalhelp.de               *
;*                                                           *
;*************************************************************


;*************************************************************
;*                          General 1                        *
;*************************************************************

autoload=2
; If you are using a version of WTOS code < 7.1_133 please use:
; Rapportserver= instead of WDMServer=
WDMServer="xxxxx"
Rapportserver="xxxxx"
SecurityPolicy=low
AdminMode=yes Username=xxxxx Password=xxxxxxx ShowAdmin=yes

;*************************************************************
;*                          General 2                        *
;*************************************************************

Inactive=0 NoSessionTimer=0
EnableGKey=yes

;*************************************************************
;*                          General 3                        *
;*************************************************************

AutoSignoff=yes Shutdown=yes
Shutdowncounter=0

;*************************************************************
;*                          Privilege                        *
;*************************************************************

Privilege=High HideConnectionManager=yes EnableNetworkTest=yes ShowDisplaySettings=Yes EnableKeyboardMouseSettings=yes DisableChangeDateTime=yes EnablePeripherals=Audio,Camera,Keyboard,Mouse
Include=$mac.ini

;*************************************************************
;*                         Peripherals                        *
;*************************************************************

Language=De
Device=audio Volume=0 Mute=3 mic_vol=5

;*************************************************************
;*                           Display                         *
;*************************************************************

DeskColor="00 22 44"
Desktop=xxxxx_Logo.jpg Layout=Stretch
Screensaver=0
ShutDownInfo=yes

;*************************************************************
;*                             Time                          *
;*************************************************************

Timeserver=ntp1.t-online.de Timeformat="24-hour format" Dateformat=dd/mm/yyyy
TimeZone='GMT + 01:00' ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName="W. Europe" DayLightName="W. Europe"

;*************************************************************
;*                           Network                         *
;*************************************************************

; If you are using a version of WTOS code < 7.1_133 please use:
; RapportDisable= instead of WDMService=
WDMService=Yes
Service=SNMPD Community=algNOC
AddCertificate=RapidSSLSHA256CA-G2.crt
AddCertificate=GeoTrustPrimaryCertificationAuthority-G3.crt
AddCertificate=hdxhqleschacoorg.crt
AddCertificate=LSC-SRV-WDM_root.cer
SignOn=Yes LastUsername=yes SaveLastDomainUser=Yes
DisableDomain=yes
DomainList="HQ" Disable=yes
PasswordServer=10.235.10.51;10.235.10.52 Connect=RDP
MaxVNCD=1
VncPassword="xxxxxx"
VncPrompt=No Accept=10

;*************************************************************
;*                       General Session                     *
;*************************************************************

SessionConfig=ALL UnmapSerials=no Smartcards=yes MapDisks=yes DisableSound=No VUSB_DISKS=yes VUSB_AUDIO=yes VUSB_VIDEO=yes DisableResetVM=yes
UniSession=yes

;*************************************************************
;*                             ICA                           *
;*************************************************************

PnliteServer=http://hdx.hq.leschaco.org/Citrix/LeschacoStorefront/PNAgent/config.xml Storefront=yes
SessionConfig=ICA SessionReliability=yes

0 Kudos

Re: PasswordServer does not work anymore

You may want to reconsider posting your entire INI.  There are probably some things in there you dont want public.

Since you are using Citrix and Storefront I would suggest changing the device to use Storefront mode

         PnliteServer=http://hdx.hq.leschaco.org Storefront=yes

remove the passwordserver= line

Add passwordnotify to your Sessionconfig=ICA line

           SessionConfig=ICA PasswordExpireNotify=yes SessionReliability=yes

Make sure the storefront server is configured to allow password changes "At any time".    The device will leverage storefront to be told when to change password for a user, and a dialog box will appear and allow the user to change password, without having to establish a session against a user.

0 Kudos
grimm00s
1 Copper

Re: PasswordServer does not work anymore

Thanks. I already change this and and I can also confirm that storefront server configured password changes to "At any time", but still does not work.

If user with expired password try to logon to Wyse Box, ThinOS open a popup-windows and confirm that password expired and ask to change to new one. But after set new password and confirm new password, nothing happens and ThinOS return to normal Logon Window again. Still can not logon with old or new password and we get into a loop.

Any other ways to implement password change servers? Until we upgrade to latest firmware it works fine with PasswordServers connection via RDP.

0 Kudos

Re: PasswordServer does not work anymore

I am sorry to hear that.  I recommend you open a support ticket. 

 

0 Kudos
grimm00s
1 Copper

Re: PasswordServer does not work anymore

How and where can I do that?
0 Kudos