XPS Desktops

Last reply by 07-03-2022 Solved
Start a Discussion
2 Jasper
2 Jasper
2924

XPS 8950, BIOS 1.0.8, slow startup

I am seeing slow startup for machine. In looking at Task Manager>Startup, last BIOS Time is 26.5 seconds. On previous machines I was seeing times less than 5 seconds. I have the latest BIOS update installed, 1.0.8, 30 Dec. 2021

Replies (30)
2 Jasper
2 Jasper
735

Fast Starup does not appear for me. I had looked at that previously as it was a good idea.

I just got off a 90 minute call with technical support. No help. Last step is for me to set BIOS storage from RAID to AHCI/NVMe and do a clean install. This was my suggestion to them. They told me if that does not help, I can call back and they will replace the motherboard!

727

@marsdavid This article has suggestions for decreasing the Last BIOS time: https://www.thewindowsclub.com/what-is-last-bios-time-in-windows-10-task-manager

 

2 Jasper
2 Jasper
726

@Vic384 This is a helpful article. In addition to a clean install, I might try disabling the DVD reader and removing HDD and graphics card to see if there is any appreciable change. 

725

@marsdavid Since the Last BIOS time is based upon hardware initialization, I would try the other things first before trying a clean install unless Windows is not installed on an SSD. 

2 Jasper
2 Jasper
721

@Vic384 Good idea. Windows is on SSD. I was going to change BIOS storage setting from RAID to AHCI/NVMe. Once I do that, SSD will no longer boot. I can try the hardware removal first. Less work overall.

10 Diamond
720

Did you try disabling Fast Startup in Windows? That's not the same thing as Fast Boot in BIOS setup.

You can't change BIOS to AHCI without configuring Windows first. So change BIOS back to RAID, and hopefully it will boot again. Assuming it does boot, you have to follow these steps to change to AHCI:

1. At the desktop, open a Cmd window, run as administrator

2. Copy-paste this command, which will start Windows in Safe Mode the next time you reboot:
bcdedit /set {current} safeboot minimal and press Enter

3. Restart the computer and tap F2 to enter BIOS setup.

4. Change the SATA operation mode from RAID to AHCI.

5. Save the change and exit Setup. Windows will automatically boot in Safe Mode.

6. Open Cmd again, as in step #1.

7. Copy-paste this command, which will start Windows in Normal Mode the next time you reboot:
bcdedit /deletevalue {current} safeboot and press Enter

8. Reboot and Windows will automatically start with AHCI drivers enabled.

And I'm still wondering what happens to BIOS Time if you uninstall Realtek...

Ron

   Forum Member since 2004
   I'm not a Dell employee

2 Jasper
2 Jasper
718

@RoHe Fast Startup checkbox not shown in Windows. Only shows Sleep and Lock (see screenshot)

I will consider all your suggestions. Work on it tomorrow. Thanks

 

 

Power_Options.png

10 Diamond
711

Are you logged into an account with administrator privileges?  According to this site, that option should be there in Win 11.

Is Hibernation enabled on the Advanced Power Settings screen for your active power plan? If not, enable it, reboot PC and look for the option to "Change settings that are currently unavailable" again.

You could also try running these commands to see if they can fix any Win 11 issues:

1. At desktop, open a CMD prompt window, Run as administrator

2. At the prompt, type in: DISM.exe /Online /Cleanup-image /Restorehealth and press Enter
Be sure to include a space in front of each / and copy any error messages when that's done.

3. Assuming no unfixed errors in  DISM, at the CMD prompt, type in: sfc /scannow and press Enter.
Be sure to include a space in front of the / and copy any errors when that's done.

4. Assuming both commands are "successful", reboot PC and look for the option to "Change settings..." in the Power plan again.

 

Ron

   Forum Member since 2004
   I'm not a Dell employee

2 Jasper
2 Jasper
682

@RoHe I had hibernation off since I usually sleep or shutdown. With hibernation on, I saw the Fast Start. I tried as was suggested. No appreciable difference. I did unplug HDD and DVD. Went from about 20 seconds to 12 seconds. Not bad. A step in the right direction. 

Thanks to all for help. I will provide updates in the coming days as to my journey to save seconds.

10 Diamond
672

@marsdavid  What's the Boot Time when both DVD and HDD are connected again?

If disabling and then re-enabling Fast Startup decreased the Boot Time to ~12 sec (with DVD and HDD connected), it sounds like there might have been a pending Microsoft update that couldn't be installed with FS enabled.

If Boot Time is routinely around ~12 sec from here on, I suspect that's the best you're ever going to get. Boot Time depends on identification and initialization of the hardware, and new PCs have so much more stuff these days, that it's slower than you might expect. 

As I said, my XPS 8930 routinely has been showing Boot Times of ~12 sec with its 9th Gen CPU and 16 GB of RAM, while your PC is more "advanced", especially with its 12th Gen CPU and probably more RAM.

NOTE: If Boot Time suddenly increases again, it's possible there's another pending Microsoft update, so just disable Fast Startup, do a full power-off shutdown, boot up and then re-enable Fast Startup again. 

Ron

   Forum Member since 2004
   I'm not a Dell employee

Latest Solutions
Top Contributor