Last reply by 11-11-2021 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9310, Ubuntu, deep sleep missing

My computer drains a lot of battery when in sleep mode.

I've tried following the steps outlined in this bug report, tried the diagnosis layed out in this question and disabled the "sign of life" options in the BIOS as described here.

I confirmed my system sleeps in the `s2idle` state. Which I suspect is the problem.

$ sudo journalctl | grep "PM: suspend" | tail -2
May 13 18:41:00 mex kernel: PM: suspend entry (s2idle)
May 13 20:52:36 mex kernel: PM: suspend exit

However I have 2 issues when trying to follow the above guides: Firstly my `/sys/power/mem_sleep` file does not contain a `deep` option:

sudo cat /sys/power/mem_sleep

And secondly I can't seem to edit the file to add a `deep` option:

$ echo deep | sudo tee /sys/power/mem_sleep
tee: /sys/power/mem_sleep: Invalid argument
$ sudo sh -c 'echo deep > /sys/power/mem_sleep'
sh: 1: echo: echo: I/O error

Not being able to close the lid and have the laptop suspend is very annoying. Any help on this would be greatly appreciated.

OS: Ubuntu 20.04, 5.8.0-26-generic / Hardware: Dell XPS 13 9310

Replies (75)

Awesome, I've tried this night to switch to AHCI and now seems to consume less watt in idle.

I've also tried to modify ACPI table to enable S3 state, the laptop go in deep mode but on the resume it shows only Dell logo and I must force an hardware switch off.


Glad to hear that. For me it absolutely solved the issue and i am happy with S0ix. Not missing S3 anymore.
It's now 4 days after i found out about that, and i am still on the same battery charge with 49% left. Awesome!

2 Bronze
2 Bronze

This does not work for me. I changed the disk mode from RAID to AHCI and my battery's still draining way too much in suspend mode. Close to 3% per hour. I have a Dell Vostro 3500 with an 11th gen processor.


On Dell Vostro 3500, the ACPI table hack works:

$ cat /sys/power/mem_sleep
s2idle [deep]



Thank you for this suggestion, I tried it and it worked. My battery consumption on a Dell XPS 13 9300 has improved to the same level you noted. It's worth calling out I did this change alone in a fresh factory reset machine, that should suffice as proof that (in my case) this change alone fixed the excessive battery drain while at sleep.

Edit: I'm using Fedora 34.



Thank you @mgru for your hint, I would like to try on my side since I do have a battery issue on my XPS 13 9310 (sold with Ubuntu pre-installed). Indeed, I'm not able to activate S3 deep sleep mode (Suspend-to-RAM). For now, #cat /sys/power/mem_sleep returns only [s2idle].

Just one question: do you know how to set the disk mode from RAID to AHCI in the BIOS on my machine? How can I even check if it's currently in RAID mode?

Thank you!

2 Bronze
2 Bronze

For the record: I also tried to switch from RAID and it made no difference. It almost ruined my Windows install, though (had to fail booting 3 times to boot into safe mode which will install the AHCI drivers). I don't really see why it WOULD have helped, either.

@gwaga i would suggest you not bother switching the hard drive mode.


Worked for me XPS 13 9310, Fedora 34.

Switched from RAID to AHCI, no problems rebooting.

It solved battery drain but, moreover,the problem with the suspend state: closing lid the system did not suspend, but the screen stayed on. For the moment it suspends correctly...

Community Manager

The S3 deep sleep mode is not available on the XPS 13 9310. This is by design.

When using a Dell Ubuntu image, the battery discharge issue was resolved with kernel update to 5.8. However, there will be some amount of battery discharge due to the Connected / Modern Standby feature. If there are any issues with battery draining with the Dell Ubuntu image, reply to the private messages sent to you by the DELL-Cares agent on your unique case number with the Service Tag, issue, etc.

If still under warranty, click the "Get help now" icon on the right to start a live chat session.
Find your Service Tag



> The S3 deep sleep mode is not available on the XPS 13 9310. This is by design.

What about XPS 13 9510 ?

I'm considering purchasing this model.

Regards, M.


Latest Solutions
Top Contributor