XPS

Last reply by 11-11-2021 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9310, Ubuntu, deep sleep missing

My computer drains a lot of battery when in sleep mode.

I've tried following the steps outlined in this bug report, tried the diagnosis layed out in this question and disabled the "sign of life" options in the BIOS as described here.

I confirmed my system sleeps in the `s2idle` state. Which I suspect is the problem.

$ sudo journalctl | grep "PM: suspend" | tail -2
May 13 18:41:00 mex kernel: PM: suspend entry (s2idle)
May 13 20:52:36 mex kernel: PM: suspend exit

However I have 2 issues when trying to follow the above guides: Firstly my `/sys/power/mem_sleep` file does not contain a `deep` option:

sudo cat /sys/power/mem_sleep
[s2idle]

And secondly I can't seem to edit the file to add a `deep` option:

$ echo deep | sudo tee /sys/power/mem_sleep
deep
tee: /sys/power/mem_sleep: Invalid argument
$ sudo sh -c 'echo deep > /sys/power/mem_sleep'
sh: 1: echo: echo: I/O error

Not being able to close the lid and have the laptop suspend is very annoying. Any help on this would be greatly appreciated.

OS: Ubuntu 20.04, 5.8.0-26-generic / Hardware: Dell XPS 13 9310

Solution (1)

Accepted Solutions
Community Manager
Community Manager

The S3 deep sleep mode is not available on the XPS 13 9310. This is by design.

When using a Dell Ubuntu image, the battery discharge issue was resolved with kernel update to 5.8. However, there will be some amount of battery discharge due to the Connected / Modern Standby feature. If there are any issues with battery draining with the Dell Ubuntu image, reply to the private messages sent to you by the DELL-Cares agent on your unique case number with the Service Tag, issue, etc.


A double space after a period is no longer needed. Today nearly every font on your PC is proportional.
Find your Service Tag

View solution in original post

Dell Accepted Solution
Replies (75)
Moderator
Moderator

Thank you! We have received the required details. We will work towards a resolution. In the meantime, you may also receive assistance or suggestions from the community members.


Social Media Support

#IWork4Dell
Find your Service Tag

Hi, I own the XPS 15 9510, running Ubuntu 20.04, 5.11.0-40-generic, and I also only see a s2idle option.

Please let us know when this will be fixed.

2 Bronze
2 Bronze

I have the identical situation. What do I need to do to be kept in the loop when a resolution is found?

2 Bronze
2 Bronze

Dell has removed deep sleep support on newer machines afaik. I have the inspiron 14 7405 and am stuck with s2sleep as well. Battery drain is really bad with it too.

I had the same problem running Arch Linux on my XPS 13 9300 model but it has been fixed since I added the `mem_sleep_default=deep` boot option. I also have both "sign of life" options and TPM disabled in the BIOS.

That is encouraging news. Any guesses as to how to add the `mem_sleep_default=deep` boot option in Ubuntu 20.04? Google has not been very friendly to me in this case. 

Thanks!

Depends on your boot-loader. I use systemd-boot but you are probably using grub, so read https://wiki.ubuntu.com/Kernel/KernelBootParameters or similar.

2 Bronze
2 Bronze

Thanks for all the insights. and sorry to see that so many others share the pain...
I've learned from this thread here that this actually is a firmware issue. where dell chose to not include deep sleep in this computer's firmware. if so i would find that very disappointing, i can't think of a single reason why anyone would appreciate a default battery drain on his suspended laptop. i'm not sure i would have purchased the device if i had known...

@bulletmark If indeed it is a firmware issue, then i doubt the boot option would help. or am i wrong?
also: before you set the boot option, did file `/sys/power/mem_sleep` contain a `deep` option which was just not selected or did it only contain the `s2idle` option? I would assume deep was present, but not selected, so your file would have looked something like this: 

sudo cat /sys/power/mem_sleep
[s2idle] deep

  

Yes, after booting without the `mem_sleep_default=deep` kernel option:

 

sudo cat /sys/power/mem_sleep
[s2idle] deep

 

Booting with the that option:

 

sudo cat /sys/power/mem_sleep
s2idle [deep]

 

Top Contributor
Latest Solutions