Last reply by 08-16-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9343 Fedora 36 UEFI A20 System is running without video hardware acceleration.

Upgraded to Fedora 36. Get error: Check your video drivers. Your system is currently running without video hardware acceleration. System information:

  Kernel: 5.18.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: Cinnamon v: 5.2.7
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: Dell product: XPS 13 9343 v: N/A serial: <filter>
  Mobo: Dell model: 0310JH v: A00 serial: <filter> UEFI: Dell v: A20
    date: 06/06/2019

  Device-1: Intel HD Graphics 5500 vendor: Dell driver: N/A arch: Gen8
    bus-ID: 00:02.0

Video playback is painfully under-performing.

Any suggestions to help Fedora 36 find the drivers?


Replies (2)
2 Bronze
2 Bronze

Found: "Initially, the imminent Fedora 36 release will remove the old fbdev driver, leaving only DRM and KMS." 

Fedora starts to simplify Linux graphics handling 

Also tried to follow these directions for Intel Graphics:

Intel Graphics - Best practices and settings for hardware acceleration? 

However, after multiple attempts:


$ sudo vainfo
error: XDG_RUNTIME_DIR not set in the environment.
libva info: VA-API version 1.14.0
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
vaInitialize failed with error code -1 (unknown libva error),exit
$ printenv | grep -i libva
$ printenv | grep -i XDG_RUNTIME_DIR


Same result if LIBVA_DRIVER_NAME=iHD. Environment variables set in /etc/profile.d.

If this LIBVA is a possible solution, perhaps someone can help me set that environment correctly.

2 Bronze
2 Bronze

Tried rebuilding Intel Media Driver. No change.

Latest Solutions
Top Contributor