XPS

Last reply by 09-01-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
160

XPS 15 7590, WD22TB4, U4320Q USB downstream ports not working

Dell U4320Q

Hello,

I never had this U4320Q USB downstream port problem when I was connecting the U4320Q to my Dell OptiPlex desktop.
<That proves that the U4320Q is functional. The fault lies with either the Laptop or the dock. Moving this thread to the XPS Laptops board. DELL-Admin>

I was trying to use the USB downstream ports on my U4320Q monitor, but they're not working. I tried connected it to the USB/TB4 port on my XPS 15 7590 but it only shows up as a USB-C monitor that way. When I connect my XPS 15 7590 to my Dell WD22TB4 dock using the TB4 cable, then connect the U4320Q to the WD22TB4 using DP-to-DP cable for video and USB-C-to-USB-C for data, it still won't work. The USB device will show up in my Device Manager as a "Universal Serial Bus devices --> Billboard device" but won't let me connect any downstream devices. Any help would be appreciated since the docking station only has three USB-A ports on it and I need more than that.

Thanks

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
157

Had to flash the firmware on my dock but it came back

View solution in original post

Reply (1)
2 Bronze
2 Bronze
158

Had to flash the firmware on my dock but it came back

Latest Solutions
Top Contributor