Last reply by 04-04-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9560, firmware 1.19.2, Alert! TPM is not detected

Followed all of the support knowledge base and some other guides, but nothing worked. Here is my situation:

1. Device Manager- not showing security devices at all (Including TPM)

2. BIOS (F2) has no option for TPM security

3. Bitlocker- off

4. TPM 2.0 firmware software and driver "TPM query failed"

5. When powering off, unplugged, wait 30 seconds, plug back in, turn on device - problem still shows up

6. When powering off, unplugged, take out battery, drain battery 60+ seconds, plug everything back- same problem

7. Downgrading to 1.15- "ME Firmware downgrade was not allowed", "Firmware update failed"

8. Admin powershell / disable-tpmautoprovisioning - device is not ready for use

9. tpm.msc - compatible TPM cannot be found


I read as much as I could, but I could not find a solution. 





If anyone could, Please help this poor student and Thanks!



Replies (64)

Thanks @fishfishmac , worked a treat for me too. Been bugging me for ages

You saved my day. It works for me. I got a warning message at the end that the PC was shut down due to high temperature but it got flashed. So Im all good!

Yeah, @GuiYomM sadly I can't help you with the reactivation of the TPM Device, since aparently doesn't have it built in. Lets hope, Dell brings out a solution fixing this mess soon.

Thanks @fishfishmac for your solution. Unfortunately it didn't fully work for me. It does remove the error message but does not reactivate the TPM module. Windows still can't find the TPM anymore and Bitlocker can't be reactivated.

Thanks this worked perfectly

2 Bronze
2 Bronze

I tried this
1) Go to Bios
2) Go to Settings/Security/UEFICapsuleFirmwareUpdates (This allows/blocks Bios updates from services such as WindowsUpdater
3) Deactivate this function
4) Boot PC & Login
5 (Maybe Optional)) Install all Windows Updates first ( Installed Bios 1.19.2 too)
6 (Maybe Optional)) Check that you dont have any Windows Updates left
7) Install Bios 1.15

Community Accepted Solution

I'm experiencing the same issue and have tried all the suggested fixes including the last post of restoring BIOS defaults and nothing fixes this issue.

I had a similar error today on my XPS 15 9560 - during bootup "Alert! TPM device is not detected." The TPM was not visible in the bios/ Windows device manager / tpm.msc

Found a 2016 solution - "restore Bios defaults" which worked for me and now no more error on boot and  also TMP visible in Bios,etc, the solution which worked for me:

  • Switch the PC off
  • Disconnect Power plug
  • Press CTRL + ESC and reinsert the power plug
  • Menu appears with 3 options(restore default, rollback,etc)
  • Select "Restore BIOS defaults"
  • Laptop will restart and the error disappeared for me.

I will check the next few days and hope this problem is not back.



2 Bronze
2 Bronze

Same issue here. 
This started for my 8/16/2020, but I do remember a bios update recently.

XPS 15 9560
Bios 1.19.2
Windows 10 Home, never had bitlocker (?), never heard of TPM

Tried TPM 2.0 updater anyway, get Query Fails message.  
Tried the shutting down with/without power connected etc.   

I have no idea how to remove the battery here and sending it somewhere for a new motherboard sounds absurd with all my data and projects on it. 

I'm glad the $2000 laptop still works but I am not under warranty.  I have a little heart palpitation every time it sleeps or boots and gives me that screen.  
Thanks for having me I pray for some software fix

Dell XPS15, 32GB RAM, 1 TB (25% full)
Win10 64bit
Steinberg UR22
Adobe Audition
All my software is legit


This is ridiculous. There's no point downgrading the BIOS to 1.15 as on a subsequent reboot, it starts flashing to 1.19.2 again, as a previous poster also experienced. 

I have a TPM module in this 9560 laptop - the order confirmation shows this. It is incredibly poor form to release a BIOS update that causes such an issue, not allow downgrading to a working version, then basically telling us to stick it where the <profane> by not providing any fix because the machine is out of warranty? And come on, who wants to pay upwards of ~£250 for extra premium support for a year just to have an issue fixed that was caused by Dell themselves? They cause an issue, they should <profane> well fix it.

Top Contributor
Latest Solutions