Last reply by 07-01-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS 15 9570, (A7) Me FW Downgrade - Request MeSpilock failed and no audio output device installed


Since the BIOS update to 1.16.2, my XPS has problems starting up.

After the Dell logo, the message "(A7) Me FW Downgrade - Request MeSpilock Failed" appears for 1-2 minutes and then he started normally. After logging in, the message "No audio output device installed" appears.

I have already searched for solutions, but nothing helps.

  • Downgrading the BIOS
  • Update the BIOS to 1.16.2
  • Intel chipset and Intel Management Engine components are updated


For the audio problem I tried to install the Realtek driver again. To do this, the current one need to be uninstalled and reboot. After the restart the new driver can be installed.

After the restart and before installing the Realtek driver, the audio output is working again and Realtek is not shown in Device Manager. After a few minutes, however, Realtek reappears in Device Manager and the audio output no longer works.


I hope someone can help me, thank you very much.

Replies (28)
2 Bronze
2 Bronze

I did the upgrade recently to BIOS 1.19.0 and same two problems happened

I did fixed the audio problem by changing the driver to HD audio

But the Me FW Downgrade error message still there

Can you please update if you get any solution?


2 Bronze
2 Bronze

i'am facing the same problem on every boot startup this (A7) Me FW Downgrade - Request MeSpilock failed appear.

It occur's after i've updated my Dell E7270 with the latest BIOS 1.28.3

Hope there will be new update from Dell to resolve this problem.

2 Bronze
2 Bronze

I have this problem. The audio solution fixed the audio problem, but the a7 fw downgrade problem remains. I can't find the solution anywhere, but this is my exact model and symptom; so, I'm going to wait for a solution here. 

2 Bronze
2 Bronze

My XPS 9570 started having the same issue from today..

2 Bronze
2 Bronze

My Precision 5520 has the same issue, (A7) Me FW Downgrade - Request MeSpilock failed. It boots occasionally, most of the time it takes around 8 retries before it boots. 


was the same here regarding the multiple attempts before it would reboot. Attempted the Bios update that usually failed because the system would not reboot to do this, and after multiple attempts, the bios installer kicked in, but after that the XPS is unbootable. Keyboard lights come on and turn off in a few seconds. Sent it in for diagnostics, will report back on what they find and ask me to shell out


got a quote for $220 to fix MotherBoard & trackpad issue. I am going for it.


How to resolve the (A7) Me Downgrade - Request MeSpiLock Failed --

xps aio 

 XPS 27 7760

i can't do nothing

i tried install bios by normal mode, by dos mode --> same message

i tried install a new windows. -->same message 


2 Bronze
2 Bronze

any solution, non what above worked!! still in same error!

Latest Solutions
Top Contributor