XPS

Last reply by 11-07-2019 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 15-9570, TB16, USB Type-C, no longer charging

Heya,

Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.

 

Replies (75)

Gh0stface,

 

Does the battery charge the laptop with the dock unattached? 
Connect the AC adapter to the Dell Thunderbolt™ Dock (TB16), and then connect the Thunderbolt 3 (Type-C) connector to the computer.

Click the link below for troubleshooting and resolving tb16 issues

 

Dell USB-C and Thunderbolt Docks (WD15, TB16 TB18DC, D6000) - BIOS Settings and Driver Installation ...

 

How to Use and Troubleshoot Dell Thunderbolt Dock TB16

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

I tried:

  • upgrading to 1.11.2 (without dock attached only AC Adapter)
  • downgrading to 1.9.1 (without dock attached only AC Adapter)
  • downgrading to 1.8.1 (with dock attached no AC Adapter)

And the problem remains the same.

I made a quick video showcasing the behaviour https://photos.app.goo.gl/5NvmqVCcr2fxPZon6

This guy appears to have had the same issue but with a wd15 https://www.dell.com/community/XPS/Dock-station-stopped-charging-my-XPS-all-of-a-sudden/td-p/7193101

Gh0stface,

Let me know if the bios downgrade works for you.

 



Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

I read reports about bios 1.10 no longer allowing charging via low power usb-c chargers.
My theory is that possibly the dock is not initially recognized as 130W charger and thus the BIOS is preventing the charging of the notebook even if it jumps to 130W later on.

The 60W->130W jump can be observed in the BIOS battery screen. I will try downgrading BIOS if nothing else works but I am sure it worked with the 1.10 upgrade before randomly stopping to work

2 Bronze
2 Bronze

Haven't exactly the same problem Charges fine with AC adaptor just doesn't work with USB C When I hover over the battery symbol it says "plugged in, charged" When I double click on battery it says plugged in discharging? Read somewhere about going back to 1.07 Bios but don't really want to try that
Top Contributor
Latest Solutions