Highlighted
1 Copper

XPS 9560 - "Plugged in, not charging" - With a twist.

Hi everyone!

I'm just gonna get straight to the point. 

(I have had the laptop for ~2 years now).

I have the regular "plugged in, not charging" problem, where the battery will deplete and the laptop will shut down WITH the original AC Adaptor plugged in. To solve this problem, I've been using a 130w USB-C charger which works fine but I lose performance - specifically the loss of an up and running GTX 1050. In the bios, the charger is "unknown".

I have had the AC Port replaced twice by the support team and Curry's PC World when it was under warranty and I also replaced it myself when the warranty period was over, the problem still persists.

A curious thing I've discovered, if I unplug the battery within the machine and plug the AC Adaptor in, the machine runs fine! This is even more peculiar as, within the bios settings, it recognises the charger as a genuine 130w adaptor!

If I plug the battery back in, I'm back to square one.

So I am wondering whether this is a motherboard issue (as I have considered for a while now) or a battery issue? I tried encoding on OBS using the nvenc encoder, it worked for a minute or so then the laptop shut down.

0 Kudos