Start a Conversation

Solved!

Go to Solution

25210

August 2nd, 2018 04:00

XPS-15 9570 with Ubuntu 18.04.1 not resuming after suspend

I have installed Ubuntu 18.04.1 in XPS 15 9570. And installed Nvidia driver 390. If I switch to Intel (Power saving mode), the system can resume back after suspending. But If I want to use the GPU by switching to NVIDIA (Performance Mode) through "Nvidia X Server Settings" wizard, I am not able to resume the system after suspending, the laptop just hangs and I have to forcefully shut down by pressing the power button.

I followed the solutions posted here, but no one is working. Even using Bumblebee is not solving the problem. Can anyone help to resolve the issue? What is the basic reason for hanging?

1 Message

November 28th, 2018 21:00

After several days of hitting my head against the wall I finally found a solution: 

  • Install official NVIDIA proprietary drivers (nor sure if needed but you probably want to do this anyways)
  • Edit /etc/default/grub 
sudo nano /etc/default/grub

make sure that the GRUB_CMDLINE_LINUX line has the following items:

GRUB_CMDLINE_LINUX="nouveau.blacklist=1 acpi_osi=! acpi_osi=\"Windows 2015\" acpi_backlight=vendor mem_sleep_default=deep"
  • update grub:

 

sudo update-grub
  • reboot
  • after computer has restarted, try suspending to see if the laptop wakes up normally

 

 

 

 

 

2 Posts

September 24th, 2018 14:00

Having the same issue - did you find a solution?

1 Message

October 14th, 2018 15:00

Having the same issue. Blacklisting nouveau and upgrading linux kernel didn't help...Did anyone find a solution?

1 Message

December 22nd, 2018 22:00

Thank you! It works!!!

1 Message

January 8th, 2019 20:00

This worked for me!

1 Message

January 30th, 2019 23:00

This worked for me as well. Thank you so much.

1 Message

April 7th, 2019 08:00

Worked for me also. Thanks a lot!

2 Posts

May 24th, 2019 03:00

Haven't tried the workaround yet, but this is without nouveau on archlinux:

https://www.dell.com/community/XPS/Dell-XPS-15-9570-Linux-5-0-11-R418-GeForce-GTX-1050-TI-Mobile/m-p/7305092#

 

I've reported this to nvidia and apparently it's a dell sbios issue.

I will also confirm this  workaround works for archlinux.

1 Message

May 28th, 2019 11:00

I have the same problem! Unfortunately the selected solution is not working. My Ubuntu 18.04 session crashes when resuming from sleep if the Nvidia proprietary driver is used on Performance mode. I have to revert to Power Saving mode (use intel) in order to be able to suspend my laptop.

1 Message

June 22nd, 2019 13:00

Following these steps worked for me on my G7 rtx 2060 running ubuntu 18.04.2 with full disk encryption. However, I found that I could no longer adjust my screen brightness. To fix that, I removed all the parts that dealt with acpi, so that the change to grub looks like this:

 

GRUB_CMDLINE_LINUX="nouveau.blacklist=1 mem_sleep_default=deep"

 

 

July 30th, 2019 19:00

The original solution did solve my suspend problem with my XPS 15 9570 running Ubuntu 18.04 and Cinnamon 3.6.7 however as noted the brightness stopped working. The line: GRUB_CMDLINE_LINUX="nouveau.blacklist=1 mem_sleep_default=deep" Returned my screen brightness control but the BIOS started complaining about Thunderbolt every restart. Adding back in the OS to the acpi info fixed everything: GRUB_CMDLINE_LINUX="nouveau.blacklist=1 acpi_osi=\"Windows 2015\" mem_sleep_default=deep"

1 Message

October 14th, 2019 09:00

Thank you very much for your awesome work ! Running perfectly fine on a XPS-15 7590 with nvidia-driver-435 installed

4 Posts

November 19th, 2019 19:00

Hey,

With having acpi_osi as Windows2015 or Windows2009 you can still get the backlight working by adding 
acpi_backlight=native or acpi_backlight=vendor, a bit depending on the luck. On my 5540 I used the acpi_backlight=native but I have heard that people with XPS use vendor.

Also I had the best battery life and most stable sleep etc with these two parameters (and the backlight is not even needed with these)

acpi_rev_override=1 acpi_osi=Linux   (you need to check that you kernel supports the acpi_rev_override)

then make the sleep deep

mem_sleep_default=deep

Also all the nouveau blacklist stuff is still goof to keep there.
My whole kernel parameters are:

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.luks.uuid=luks-******** rd.lvm.lv=fedora_localhost-live/swap rhgb quiet rcutree.rcu_idle_gp_delay=1 acpi_rev_override=1 acpi_osi=Linux mem_sleep_default=deep systemd.unified_cgroup_hierarchy=0"


Last one is to make Docker work with new kernel...

No Events found!

Top