Start a Conversation

Solved!

Go to Solution

2260

February 1st, 2023 10:00

CPU wont go over 27%

Hello, yesterday I had a power outage while working on my dell precision laptop with battery not inside. After the power outage there was a dramatic performance drop and I noticed that the CPU will never go over 20% in task manager, no matter how much it had to handle. Everything was just very slow and the CPU was constantly on 20% or lower. In my power plans everything is set to highest performance. I entered BIOS and disabled Intel speedstep and the result is that now the CPU will never go over 27%, even if clearly it's not enough to cope with what I am doing. The CPU just stays at 27% and software is slowing down. Any idea how to fix this?

My laptop - Dell Precision 7520 

CPU - Intel(R) Xeon(R) CPU E3-1545M v5 @ 2.90GHz 2.90 GHz

OS - Windows 10 Pro

BIOS Version - 1.27.0

4 Operator

 • 

4K Posts

February 2nd, 2023 00:00

I had the exact same problem. If I went under Task Manager > Performance, I found that CPU usage would not go over 30%, and the Speed was clocked down to 0.78GHz.

At the bottom of the Performance tab there is a button to Open Resource Monitor. From here I found that Maximum Frequency was capped at 30%. (This should instead be showing at about 100%). This defines the maximum speed percentage which Windows will allow the CPU to run at.

 

I tried adjusting everything within Windows Battery and Performance settings that I found here and on other forums, but to no avail.

I finally found that I needed to prevent the "intelppm" service from starting (and subsequently malfunctioning), using the registry. This may especially be the case when slowness occurs on Laptops which are currently plugged in.

To do that:

  1. Simultaneously press the Windows image + R keys to open the 'Run' command box.
  2. In run command box, type regedit press Enter to open the Registry Editor.
  3. At the left pane, navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\intelppm

At the right pane:

-Double click the "Start" key.

-Modify the value data from '3' to '4'

-Click OK.

-Restart the PC

After that the CPU was no longer being clocked down to a low speed, and the Maximnum Frequnency under Resource Manager now shows as 100%.

Moderator

 • 

25.4K Posts

February 2nd, 2023 04:00

We tried reaching you on a private message asking for the Service Tag number to ascertain the warranty but did not receive a response. Please feel free to reply to the private message whenever you are available.

February 2nd, 2023 08:00

thanks Adrian my CPU is no longer restricted and everything works fine for now

June 20th, 2023 15:00

The following will also disable the IntelPPM service

In the windows search type cmd

In the result CMD right click and run as administrator

copy and paste the following into the CMD windows and press enter

 

%windir%\system32\sc config "intelppm" start= disabled

-Restart the PC

After  reboot confirm CPU Maximnum Frequnency under Resource Manager now shows as 100%.

 

 

 

 

1 Rookie

 • 

5 Posts

June 24th, 2024 21:48

@AdrianG001​ Thanks man :) That solved my problem.

No Events found!

Top