Start a Conversation

Solved!

Go to Solution

26845

October 16th, 2022 12:00

Dell Support Assist fails to install

XPS 13 9380

XPS 13 9380

Dell Support Assis told me today that there was a new version and took me to the new version download. it failed without telling me why but just said i have to reboot. after several reboots i removed the old version using windows 11 remove app option and tried again. still wont complete the installation of the new version.

Can anybody Help?

I run support assist weekly to keep my drivers up to date, so really need it.

thanks

Michael

 

Community Manager

 • 

2.2K Posts

October 19th, 2022 07:00

Please follow this steps to resolve this issue:

1. Uninstall any previous builds of SupportAssist using the MS Install Uninstall Tool and restart the system.
2. .NET Runtime 6.0.9 is a pre-requisite for SA v3.12.x to install successfully. It needs to be installed before installing SA using MSI and MSP files
  Link to .NET Runtime Installer (Version 6.0.9).
  If your PC is already on .NET runtime 6.0.10 or higher version, then uninstall .NET runtime 6.0.10 (or higher version) first and install .NET runtime 6.0.9 using the above link.
3. Install SupportAssist using MSI and MSP files (Links below):
  MSI: https://dl.dell.com/serviceability/catalog/SupportAssistx64-3.12.3.5.msi
  MSP: https://dl.dell.com/serviceability/catalog/SupportAssistx64-3.12.3.5.msp

 

(edited)

October 20th, 2022 12:00

HI, i read your email and followed the instructions Dell gave you (I'm not as sensitive about removing .net 6.0.10 and going back to 6.0.9 temporarily - as you can just reinstall 6.0.10 afterwards...) Guess what - it worked... Support assist then installed correctly and is now working happily.

A quick Windows Update, brought back 2022-10 .NET 6.0.10 Security Update for x64 Client (KB5019351. So i now have Support Assist back installed and working and am using the latest version of .net again.

3 Apprentice

 • 

1.2K Posts

October 15th, 2023 15:27

Hi Denny_Emart:


This thread was started in October 2022 when users were having problems installing SupportAssist v3.12.3.  Most of the information in this thread is outdated and does not apply to newer versions of SupportAssist v3.14.0 and higher.


I no longer use SupportAssist (I now use Dell Update for Windows Universal v5.x to check for Dell software and driver updates) but If you are having issues installing the latest SupportAssist v3.14.4 then try a clean reinstall as instructed at SupportAssist for PCs and Tablets Clean Uninstall and Reinstall. The companion YouTube video at SupportAssist Clean Reinstall (Official Dell Tech Support) demonstrates how to perform a clean reinstall.


NOTE: After you have cleaned all traces of SupportAssist off your system and are ready to reinstall with the latest version of SupportAssistInstaller.exe I suggest you save that installer to your Windows desktop, right-click, and choose "Run as Administrator".

Before you start your clean reinstall you should ensure that Windows Update has installed your October 2023 Patch Tuesday updates that were released on 12-Oct-2023.  One of your images shows that both your MS .NET (Core) Runtimes are several months out-of-date.  From my Dell Inspiron 5584  \ Win 10 v22H2 computer:

 

If none of this helps then please post back and tell us your Dell computer model and Windows operating system (if Win 10 or Win 11 include the version and build shown at Settings | System | About | Windows Specifications).  This old thread has already been marked as solved so if you need further assistance then you might want to start a new topic by clicking the blue "Start a Discussion" button in this Dell SupportAssist for Home PCs board so your question receives more attention.
------------
Dell Inspiron 5584 * Dell Inspiron 5583/5584 BIOS v1.22.1 * 64-bit Win 10 Pro v22H2 build 19045.3570 * Firefox v118.0.2 * Microsoft Defender v4.18.23090.2008-1.1.23090.2007 * Malwarebytes Premium v4.6.4.286-1.0.2163 * Macrium Reflect Free v8.0.7690 * Dell Update for Windows Universal v5.0.0 * My Dell v2.2.6.0

(edited)

1 Message

October 18th, 2022 01:00

I have the exact same problem as you on my Windows 11 PC.

Contacted Dell support who spent 2 hours remotely logged into my PC.

Their solution...

"For this issue, we request you please perform the operating system reinstallation."

I have not had any issues on my PC so I am not at all happy to carry out this procedure.

I have asked them to escalate to the Dell Support Assist developers but they insist I must reinstall the Windows 11 O/S before they do this.

 Dell's SA app update procedure that is causing the problem not Microsoft.

At present I am waiting to hear back from them,

Thanks,

John

 

 

 

 

1 Message

October 19th, 2022 09:00

When I execute the SupportAssistx64-3.12.3.5.msi I get the error message "UI mode not supported" on Windows 11 Enterprise 22H2.

How can I resolve this?

Thanks,

Jürgen

October 20th, 2022 02:00

Hi @DELL-Nathalia M 

If MSoft publish a new version of .NET runtime, there is surely good reason for that. Most likely, to avoid some security issue. It is indeed what is indicated in  MSoft Catalog  : .NET 6.0.10 is indeed a security update (KB5019351)

While, I repeat again,  I'm convinced there is no conflict between DSA and .Net 6.0.10 : For me, the most likely reason of the issue is that, at install, DSA checks if AT LEAST .Net 6.0.9 is installed. And when it founds that 6.0.10 version is installed, it compares this version number wit 6.0.9, but erroneously makes its comparision alphabetically instead of numerically (and, yes, alphabetically speaking, 6.0.10 is "before" 6.0.9). As a result, DSA considers that .NET has to be "upgraded" to 6.0.9 which is (hopefully !) impossible from .NET perspective.

So, rather than to ask users to do such things, please ask technical engineers to create a new version of DSA installer that, when it checks currently installed version of .NET, is able to understand that if minimum version is 6.0.9, this requirement is already fulfilled if 6.0.10 is already installed.

Or, in case there is really incompatibility of DSA with 6.0.10 (I don't believe it 1 second), fix DSA itself to resolve the conflict... or ask MSoft to publish a 6.0.11 that solve the issue.

But surely, I won't downgrade an "OS layer soft" (ie. .NET runtime) to "please" a "User layer" soft (ie. DSA).

3 Apprentice

 • 

1.2K Posts

October 21st, 2022 09:00

Hi @DELL-Nathalia M :

Just an FYI that the SupportAssist v3.12.3.5 .MSI installer that downloads from the link (https://dl.dell.com/serviceability/catalog/SupportAssistx64-3.12.3.5.msi) you provided in your instructions <above> has an incorrect MIME type and downloads as a plain text file in my Firefox browser. See my 21-Oct-2022 thread Some .MSI Files Downloaded as Garbled Plain/Text in Firefox v106.0.x which confirms that Dell needs to fix this problem on their web server. Note: the SupportAssistx64-3.12.3.5.msi file will download correctly in my Firefox browser if I right-click that download link and choose "Save Link As"; the .msi file will also download correctly in my MS Edge browser.

See the section titled "File Types and Download Actions" in the Mozilla Firefox support article Manage File Types and Download Actions, which states in part that:


... " Firefox will not be able to properly handle a file if a misconfigured web server sends it with an incorrect content type. For example, Firefox may display the content as plain text instead of opening the file in an application. To learn more, see Properly configuring server MIME types and Common MIME types at MDN web docs. You can contact the website in such cases, or you can try a Firefox add-on such as Content-Type Fixer to work around the problem... "

Also note that Delphine R reported <here> that the SupportAssistInstaller.exe stub installer (installation manager) available on the main SupportAssist for Home PCs download page can also be used in Step # 3 of your instructions. Perhaps you could add that download link for users who are currently unable to download the .MSI installer with their browser while you are waiting for Dell to fix the MIME type of their .msi files.
-----------
64-bit Win 10 Pro v21H2 build 19044.2130 * Firefox v106.0.1 * Microsoft Defender v4.18.2209.7-1.1.19700.3 * Malwarebytes Premium v4.5.16.217-1.0.1792 * Macrium Reflect Free v8.0.6979 * Dell SupportAssist v3.12.3.5 * Dell Update Windows Universal v4.6.0 * Inspiron 5583/5584 BIOS v1.21.0
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620

November 2nd, 2022 07:00

I also got the UI error. And SA assist from Dell's support page didn't work. I followed the steps regarding .NET versions. I don't have previous versions of SA installed, I'm trying to get it back after restoring my Windows 11 system. I'm on a Dell XPS 15 9570. Hope someone has any news about this widespread and old issue. Thanks

9 Posts

November 4th, 2022 13:00

By using Visual Studio, I'm tied to the latest versions of .NET.  There is no option for me to revert to an out-of-date version without removing my business required software.  As a developer, the concept that you are tied to a subversion (that changes monthly) is absolutely insane.

.NET 6.0

  1. 6.0 Nov 8 2021
  2. 6.0.1 Dec 14 2021
  3. 6.0.2 Feb 8 2022
  4. 6.0.3 Mar 8 2022
  5. 6.0.4 Apr 12 2022
  6. 6.0.5 May 10 2022
  7. 6.0.6 Jun 14 2022
  8. 6.0.7 Jul 12 2022
  9. 6.0.8 Au 9 2022
  10. 6.0.9 Sep 13 2022
  11. 6.0.10 Oct 11 2022

3 Apprentice

 • 

1.2K Posts

November 5th, 2022 07:00



Hi nxtwothou:

Just to clarify, the original poster of this thread, Michael.Strachan, posted <above> on 20-Oct-2022 that you only need to temporarily downgrade to MS .NET Runtime v6.0.9 in order to install SupportAssist v3.12.3.5. Once SupportAssist is installed you can run Windows Update to patch back to the latest MS .NET Runtime v6.0.x (i.e, v6.0.10 or higher) and SupportAssist should (hopefully) continue to run correctly with future versions of MS .NET Runtime v6.0.x as long as you've followed all the steps in DELL-Nathalia M instructions <here>. It seems that the SupportAssist v3.12.3.5 installer is not smart enough skip over the installation of .NET Runtime v6.0.9 when a newer (and more secure) version of .NET Runtime v6.0.x is already installed.

I completely agree that this isn't an ideal solution and that Dell should fix this glitch in their installer, but are you saying that it's impossible to uninstall the current MS .NET Runtime v6.0.10 (rel. 11-Oct-2022) from Control Panel | Programs | Programs and Features and temporarily downgrade to MS .NET Runtime v6.0.9 as long as Visual Studio is installed on your computer, or did I misunderstand your comment?
-------------
64-bit Win 10 Pro v21H2 build 19044.2130 * Firefox v106.0.5 * Microsoft Defender v4.18.2210.4-1.1.19700.3 * Malwarebytes Premium v4.5.17-221-1.0.1806 * Macrium Reflect Free v8.0.7090 * Dell SupportAssist v3.12.3.5 * Dell Update Windows Universal v4.7.0 * Inspiron 5583/5584 BIOS v1.21.0
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620

November 11th, 2022 18:00

It did not work for me. I followed the instructions to the letter. My PC is a Dell Inspiron 20 Model 3048. It is working at about 1/10 of normal speed even after I downloaded and installed all the Windows updates that were available. My PC has become a useless toy. Is there any other way I can find out why?

3 Apprentice

 • 

1.2K Posts

November 11th, 2022 20:00


@frank14612 wrote:

... My PC is a Dell Inspiron 20 Model 3048. It is working at about 1/10 of normal speed even after I downloaded and installed all the Windows updates that were available. My PC has become a useless toy....


Hi frank14612:

You posted today in gadix's 15-May-2021 thread SupportAssist Not Installing - Download Failed  that you have an unsupported Win 10 v20H2 OS (Build 19042.1165) that has not been updated since 10-Aug-2021. Instead of cross-posting in multiple threads it would be better if you started your own topic here in the SupportAssist for PCs board and posted all relevant information there, including your Dell computer model, Windows OS [include the edition (e.g., Home, Pro, etc.), version and OS build number shown at Settings | System | About | Windows Specificatons], name and version of your antivirus, and current BIOS version. To find your BIOS version enter msinfo32 in a Run dialog box to open your System Information panel and look for the field titled "BIOS Date/Version".
-------------
64-bit Win 10 Pro v21H2 build 19044.2130 * Firefox v106.0.5 * Microsoft Defender v4.18.2210.6-1.1.19800.4 * Malwarebytes Premium v4.5.17.221-1.0.1806 * Macrium Reflect Free v8.0.7090 * Dell SupportAssist v3.12.3.5 * Dell Update for Windows Universal v4.7.0 * Inspiron 5583/5584 BIOS v1.21.0
Dell Inspiron 15 5584, Intel i5-8265U CPU, 8 GB RAM, 256 GB Toshiba KBG40ZNS256G NVMe SSD, Intel UHD Graphics 620

November 12th, 2022 18:00

It's still not solved. I've been working on my PC all day, following your instructions, and it has not worked. Is there anything else I can do to get SupportAssist to work?

 

 

5 Posts

January 6th, 2023 07:00

Hello Nathalia,

I've a question regarding your solution. I just bought Dell XPS 9520, and I've the same problem with using the SupportAssist 3.10.33.

My Dell XPS comes with .NET Runtime 6.0.9 preinstalled, and this is the only version which is installed on my laptop.

After the first run of SupportAssist 3.10.33 the software is checking for a new version of SupportAssist and trying to install newer version but unfortunatelly after I got a message "Newer version is available, and it will be installed", when I hit "Yes" I got a message: "Installation failed. Restart your computer and try again". After restarting my computer and running the SupportAssist again, the situation recur.

I can install all the updates using the older version of SupportAssist 3.10.33, but I can't update Dell SupportAssist OS Recovery Plugin and SupportAssist to the newest version.

I would be grateful if you could let me know what I should do in this situation? Should I follow your steps to resolve my issue? Should I install SupportAssist using MSI and MSP files, but which should I install as first?

Thank you,

Kindest regards,

Radek

 

 

 

1 Rookie

 • 

18 Posts

January 21st, 2023 04:00


@DELL-Nathalia M wrote:
3. Install SupportAssist using MSI and MSP files (Links below):
  MSI: https://dl.dell.com/serviceability/catalog/SupportAssistx64-3.12.3.5.msi
  MSP: https://dl.dell.com/serviceability/catalog/SupportAssistx64-3.12.3.5.msp

 



MSI install  fails: 

GillesP_0-1674304789631.png

 

No Events found!

Top