Start a Conversation

Unsolved

M

1 Rookie

 • 

1 Message

46

February 26th, 2024 03:31

XPS 15 9530, BIOS attack?

I am connected to the internet, but the drivers won't update in SupportAssist. I get a message UNABLE TO CONNECT TO THE INTERNET VERSION 3.14.2.45116 I ran the troubleshooter - it says it's connect, but goes through the same issue again. everything seems to working fine, except when connecting to Dell Supportassist & trying to upload / update drivers. and I'm concerned about this BIOS 'attack' as mentioned in Dell Trusted Device.

3 Apprentice

 • 

1.1K Posts

February 29th, 2024 14:30

Hi @MikeMart :

What is your Windows operating system [please include the edition (Home, Pro, etc.), version and OS build number shown at Settings | System | About | Windows Specifications] and antivirus?

What is your current BIOS version? Open a Run dialog box (Win key + R), enter msinfo32 to open your System Information window, and look for the field named "BIOS Version / Date" in the summary.  The support page for the XPS 15 9530 support page at https://www.dell.com/support/home/en-us/product-support/product/xps-15-9530-laptop/drivers is currently recommending Dell XPS 15 9530 System BIOS v1.10.0 (released 19-Jan-2024).  

NOTE: I normally recommend that users do NOT allow Windows Update or Dell utilities like SupportAssist v4.x or Dell Update v5.x to install BIOS updates.  See my post in DrCarlSagan's Alienware m15 R5 Ryzen Edition (Windows 11): SupportAssist doesn't recognize BIOS update version 1.17.0 (Released: Feb. 20, 2024) about safer methods you can use to manually update your BIOS

If you go to Control Panel | Programs | Programs and Features does it show that you have the latest SupportAssist v4.0.0 (released 01-Feb-2024 - see the release notes and user guide at https://www.dell.com/support/home/en-us/product-support/product/dell-supportassist-pcs-tablets/docs).  Multiple users have been posting about problems using SupportAssist since Dell started rolling out v4.0.0 in early February 2024, and according to paojw's 21-Feb-2024 post <here> Dell Customer Support is aware of these issues.  I would recommend that you use an alternate method (e.g., like the Dell Update v5.x utility) to check for updates until Dell resolves these problems and/or releases a newer version of SupportAssist v4.0.x that includes bug fixes. 

Go to Control Panel | Programs | Programs and Features and see if Dell Command | Update for Windows Universal v5.2.0 is installed.  If not, browse to the XPS 15 9530 support page at https://www.dell.com/support/home/en-us/product-support/product/xps-15-9530-laptop/drivers, click the This Device tab on your support page as shown below and enter your unique Service Tag to filter the results for software and hardware drivers that match your system components ***. If the Dell Command | Update Windows Universal Application v5.2.0 (released 31-Jan-2024) is still recommended then download the Dell-Command-Update-Windows-Universal-Application_0XNVX_WIN_5.2.0_A00.EXE installer from that support page, save it to your desktop, right-click the .exe file, and choose "Run as Administrator".  Then run a check for updates with this utility to see if it finds any available updates.

NOTE: If you can't see the list of recommended updates on your support page see the workaround garrioch7 suggested in my October 2023 topic Recommended Updates (View List) Not Displayed on Inspiron 15 5584 Support Page (i.e.,  click the blue Check for Updates button on your support page and chose Cancel if it prompts you to install SupportAssist).  I'm still having problems viewing the list of available updates on my Inspiron 5584 support page and on occasion I even have to use MS Edge instead of my default Firefox browser.

If you prefer, you can also use the XPS 15 9530 support page at https://www.dell.com/support/home/en-us/product-support/product/xps-15-9530-laptop/drivers to look for available updates for any outdated software or hardware drivers as described above and then download and run the required .exe installers manually.  Just remember to enter your unique Service Tag first so that you are only offered updates that match your system components.  Note that the blue "Check for Updates" button on that support page will not work if SupportAssist is not functioning correctly.
--------------
Dell Inspiron 15 5584 * 64-bit Win 10 Pro v22H2 build 19045.4046 * Firefox v123.0.0 * Microsoft Defender v4.18.24010.12-1.1.24010.10 * Malwarebytes Premium v4.6.9.314-1.0.2276 * Macrium Reflect Free v8.0.7783 * Dell Update for Windows Universal v5.2.0 * My Dell v2.2.6.0

(edited)

5 Practitioner

 • 

2.4K Posts

March 3rd, 2024 16:27

Naah its an ongoing problem since they released 4.0 

Everytime a major release is done we get such bugs 
I have a case open with their engineering team for the exact same issue. 

They have worked remotely twice so far with no fix. 

Use Dell update app instead for updating drivers until it's fixed. 
I will keep this thread updated

No Events found!

Top