NetWorker: Unable to log in to NMC or using nsrlogin, receiving: "Authentication library error: GET failed with HTTP-ERROR: 404"

Summary: Unable to log in to the NMC or using the nsrlogin command from the CLI on the NetWorker server. This KB goes over this issue/resolution when it is also found that the nsr directory on the NetWorker server is at 100% capacity. ...

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Symptoms

  • You are unable to log in to the NetWorker Management Console (NMC) or CLI using nsrlogin  
  • NetWorker authentications fail with the following error:
HTTP 404 appears during NMC login
Authentication library error: GET failed with HTTP-ERROR: 404
Server Message : Could not parse server-response from json string
Server Message : Make sure that server is running
  • NetWorker server (nsrd) service is running:
    • Linux: ps -ef | grep nsr
    • Windows: tasklist | findstr nsr
  • Port 9090 is listening:
    • Linux: netstat -apno | grep 9090
    • Windows: netstat -ano | findstr 9090
    • NetWorker port test command: nsrports -t localhost -p 9090

Cause

This issue can appear due under different circumstances:
  • After upgrade/installation of NetWorker on a Windows based server
  • The /nsr installation location has reached 100% capacity
  • Authentication Server (AUTHC) database corruption

The AUTHC service has started but is unresponsive to authentication requests.

Resolution

Before any steps are taken to resolve the issue, confirm that the installation drive is not at 100% capacity. If the installation drive is full, or nearing capacity, increase disk space accordingly.

The AUTHC database must be reconfigured.

Linux:

1. Shutdown NetWorker services: nsr_shutdown
2. Rename the AUTHC directory: mv /nsr/authc​​​​ /nsr/authc`date -I`.bak
3. Run the AUTHC configuration script: /opt/nsr/authc-server/scripts/authc_configure.sh
NOTE: You are prompted to reconfigure the AUTHC keystore and NetWorker Administrator password.
4. Start NetWorker services: systemctl start networker
5. Confirm NetWorker services come up: ps -ef | grep nsr
6. Confirm port 9090 connections succeed: nsrports -t localhost -p 9090
NOTE: The AUTHC service appears as a jsvc.exe process for nsrtomcat+. This can be observed with `ps -ef | grep jsvc`

7. Log in to the NMC or NetWorker Web User Interface (NWUI) using the NetWorker Administrator account.
8. Once NetWorker functionality is returned, you can delete the old AUTHC folder at your discretion.

Windows:

1. Uninstall NetWorker.
2. From Windows File Explorer, go to the NetWorker installation directory and rename the authc-server folder. The default location is "C:\Program Files\EMC NetWorker\nsr\authc-server"
3. Reinstall NetWorker.

NOTE: NetWorker installation packages can be downloaded from: https://www.dell.com/support/home/product-support/product/networker/drivers. During the installation, you are prompted to re-create the NetWorker keystore and default Administrator password.

4. Confirm NetWorker services come up: tasklist | findstr nsr
5. Confirm port 9090 connections succeed: nsrports -t localhost -p 9090

The AUTHC process is listed as a java.exe process. The Details tab in Task Manager can be used to identify this process: 
Authc process 

6. Log in to the NMC or NetWorker Web User Interface (NWUI) using the NetWorker Administrator account.
7. Once NetWorker functionality is returned, you can delete the old AUTHC folder at your discretion.

Additional Information

Affected Products

NetWorker, NetWorker Management Console

Products

NetWorker Family, NetWorker, NetWorker Series
Article Properties
Article Number: 000031476
Article Type: Solution
Last Modified: 20 Jun 2025
Version:  5
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