NVP-vProxy Plugin Install from NMC fails with message failed to install vCenter plug-in
Summary: NVP-vProxy Plugin Install from NMC fails with message failed to install vCenter plug-in.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
NVP-vProxy Plugin Install from NMC fails with message failed to install vCenter plug-in.
Cause
Installing the NetWorker NVP-vProxy vCenter plug-in is done from the NMC in the Protection Screen by right-clicking 'VMware View' and selecting 'Install vCenter Plugin'
This fails with the following Message:
Or it will stuck on the installing message forever:
NetWorker-vProxy: How-To Remove vProxy plug-in from vCenter Server.
This fails with the following Message:
Or it will stuck on the installing message forever:
NetWorker-vProxy: How-To Remove vProxy plug-in from vCenter Server.
Resolution
To find out why this fails, a debug log file of the operation must be generated by using the following steps:
1. On the NetWorker Management Console (NMC) client, enable the Java console.
When NetWorker Runtime Environment (NRE) is installed, the Java Control Panel can be accessed in the NRE install location:
C:\Program Files\NRE\java\jre<version>\bin\javacpl.exe
If Oracle Java Runtime environment is installed, open "Run" [CTRL+R] and enter:
javaws -viewer
From the Java Control Panel, go to the Advanced tab, and click Show Console:
2. Launch the NMC and log in.
3. In the Java Console, enter 5.
4. Go to the Protection tab and attempt the vSphere plug-in installation again.
5. Copy the java debug output to a notepad file using the "copy" button in the console and examine it for errors.
On the NetWorker server, review the vcui.log for failures during the plug-in installation:
Linux: /nsr/authc/logs/vcui.log
Windows: C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\vcui.log
Scenario
Found this in the logs:
network: Connecting https://nwserver1:9090/ebr-server/networker/session/connect" https://nwserver1:9090/ebr-server/networker/session/connect with proxy=DIRECT
network: Connecting socket://nwserver1:9090 with proxy=DIRECT
java.netUnknownHostException: nwserver1
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
The 'UnknownHostException' is being generated because the NetWorker server host (in this case called nwserver1) was not known to the NMC client. Adding the IP address and hostname of the NetWorker server to the NMC client's hosts file resolved the issue. The NMC client is the host whose browser you are using to access the NMC server.
NVP-vProxy Plugin Install from NMC on NetWorker fails with message failed to install vCenter plug-in.
You can also view this video on YouTube.
1. On the NetWorker Management Console (NMC) client, enable the Java console.
When NetWorker Runtime Environment (NRE) is installed, the Java Control Panel can be accessed in the NRE install location:
C:\Program Files\NRE\java\jre<version>\bin\javacpl.exe
If Oracle Java Runtime environment is installed, open "Run" [CTRL+R] and enter:
javaws -viewer
From the Java Control Panel, go to the Advanced tab, and click Show Console:
2. Launch the NMC and log in.
3. In the Java Console, enter 5.
4. Go to the Protection tab and attempt the vSphere plug-in installation again.
5. Copy the java debug output to a notepad file using the "copy" button in the console and examine it for errors.
On the NetWorker server, review the vcui.log for failures during the plug-in installation:
Linux: /nsr/authc/logs/vcui.log
Windows: C:\Program Files\EMC NetWorker\nsr\authc-server\tomcat\logs\vcui.log
Scenario
Found this in the logs:
network: Connecting https://nwserver1:9090/ebr-server/networker/session/connect" https://nwserver1:9090/ebr-server/networker/session/connect with proxy=DIRECT
network: Connecting socket://nwserver1:9090 with proxy=DIRECT
java.netUnknownHostException: nwserver1
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
The 'UnknownHostException' is being generated because the NetWorker server host (in this case called nwserver1) was not known to the NMC client. Adding the IP address and hostname of the NetWorker server to the NMC client's hosts file resolved the issue. The NMC client is the host whose browser you are using to access the NMC server.
NVP-vProxy Plugin Install from NMC on NetWorker fails with message failed to install vCenter plug-in.
You can also view this video on YouTube.
Affected Products
NetWorkerProducts
NetWorker, NetWorker SeriesArticle Properties
Article Number: 000036141
Article Type: Solution
Last Modified: 23 Sept 2024
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.