Unable to Activate Users in Dell Encryption or Dell Data Protection Encryption Due to Missing Network Provider Data in Registry
Summary: Unable to activate users due to missing Network Provider data in registry in Dell Encryption (formerly Dell Data Protection Encryption).
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Symptoms
Affected Products:
- Dell Encryption
- Dell Data Protection | Encryption
Users are unable to activate on the endpoint; even though all other configuration data is present.
Shield Log:
[10.13.14 14:14:12:385 GinalessEEObjec: 1238 H] [SUPPORT] Event Engine - User credentials required for activation are missing - prompting the user [10.13.14 14:14:12:385 GinalessEEObjec: 1233 E] Event Engine - User activation request could not be processed because we did not receive auth information
DDPE_Installer Log:
-- MSI_LOGGING -- *** CMsiRemoveNetworkProviderString -- Checking whether to remove CMGShieldNP to network provider order -- MSI_LOGGING -- *** CMsiRemoveNetworkProviderString -- Initial value of provider order: CMGShieldNP,RDPNP,LanmanWorkstation,webclient,LMIRfsClientNP -- MSI_LOGGING -- *** CMsiRemoveNetworkProviderString -- Final provider order: RDPNP,LanmanWorkstation,webclient,LMIRfsClientNP (Note that CMGShieldNP is missing)
Cause
CMGShieldNP is missing from the NetworkProvider registry keys.
Resolution
Add or Edit the following registry keys:
Warning: The next step is a Windows Registry edit:
- Back up the Registry before proceeding, reference How to Back Up and Restore the Registry in Windows
.
- Editing the Registry can cause the computer to become unresponsive on the next reboot.
- Contact Dell Data Security International Support Phone Numbers for assistance if you have concerns about performing this step.
HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder:ProviderOrder – add CMGShieldNP to the front of the list. HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order:ProviderOrder – add CMGShieldNP to the front of the list.
To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.
Affected Products
Dell EncryptionArticle Properties
Article Number: 000124137
Article Type: Solution
Last Modified: 03 Oct 2023
Version: 10
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