Cloud Disaster Recovery : La suppression par Amazon Web Services (AWS) de la prise en charge de Python 2.7 au 15 juillet 2021 peut avoir un impact sur les clients Cloud Disaster Recovery, ce qui entraîne potentiellement une indisponibilité des données.

Résumé: Depuis le 15 juillet 2021, AWS ne prend plus en charge Python 2.7 dans la CLI AWS, ce qui peut entraîner des problèmes pour Cloud DR.

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Depuis le 15 juillet 2021, AWS ne prend plus en charge Python 2.7 dans la CLI AWS, ce qui entraîne les problèmes suivants pour Cloud DR :
  • Nouveaux déploiements de toutes les versions de Cloud DR
  • Déploiements existants :
    • Exécution de la récupération sur toutes les versions de Cloud DR Rétention sur les versions 19.7 et 19.8 
Qu’est-ce qui est concerné ?
Produits :
Tous les produits associés à Cloud DR sont concernés par ce problème (appliances PowerProtect DP, PPDM, Standalone Cloud DR et RecoverPoint for VM).

Clients :
Tous les clients Cloud DR utilisant AWS ou AWS GovCloud comme Cloud cible sont affectés.

Fonctionnalité :
Nouvelles installations Cloud DR :
  • Échec du déploiement du CDRS dans AWS ou AWS GovCloud (impactant toutes les versions de Cloud DR).
Déploiements Cloud DR existants : 
  • Échec de l’exécution des flux de récupération dans AWS ou AWS GovCloud (problème concernant toutes les versions de Cloud DR).
  • Échec de l’exécution des flux de rétention dans AWS ou AWS GovCloud (problème concernant les versions 19.7 et 19.8 de Cloud DR).
Cela n’affecte pas :
  • Les déploiements Cloud DR existants, qui peuvent toujours exécuter la protection vers AWS ou AWS GovCloud.
  • Les clients Cloud DR utilisant des solutions Cloud Azure et Azure Government.

Solution de contournement :
Le nouveau déploiement de Cloud DR Server dans AWS ou AWS GovCloud nécessite l’utilisation d’un nouveau module d’installation de l’un des nouveaux correctifs publiés.

Cause

Le problème est dû à l’arrêt de la prise en charge de Python 2.7 par AWS. Consultez les informations relatives à Amazon EOS :
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/.

Résolution

Voici les deux options de résolution pour les clients concernés : le Tableau 1 propose de nouveaux correctifs de déploiement et de mise à niveau ; le Tableau 2 propose une solution de contournement comme alternative aux clients qui ne choisissent pas de procéder à une mise à niveau.

Tableau 1
Produit (système d’exploitation ou environnement d’exploitation)
  • Cloud Disaster Recovery (Cloud DR) version 19.8 et versions antérieures avec AWS ou AWS GovCloud
  • Tous les produits associés à Cloud DR avec AWS ou AWS GovCloud peuvent être affectés par ce problème
    • PowerProtect DP Appliances ou Integrated Data Protection Appliance (IDPA)
    • PowerProtect Data Manager (PPDM)
    • Standalone Cloud DR (PowerProtect DD ou Data Domain et Avamar)
    • RecoverPoint for VMs
Problème résolu dans ce système d’exploitation, cet environnement d’exploitation ou ce logiciel Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 et 19.1.0.6
TYPE D’ACTION MISE À NIVEAU
Qui peut effectuer l’action ? CLIENT
Détails de la résolution Pour le nouveau déploiement de Cloud DR :
Mettre à niveau (ou utiliser) Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2 ou 19.2.0.5

Pour les clients Cloud DR PowerProtect ou IDPA :
Clients de IDPA version 2.6.1 : Mise à niveau vers Cloud DR 19.6.0.2
Clients de IDPA version 2.6.0 : Mise à niveau vers Cloud DR 19.5.0.2
Clients de IDPA version 2.5.0 : Mise à niveau vers Cloud DR 19.2.0.5
Clients de IDPA versions 2.4.1 et 2.3.1 : Mise à niveau vers Cloud DR 19.1.0.6

Remarque :
Clients d’IDPA versions 2.4.0 et 2.3.0 : consultez la section « SOLUTION DE CONTOURNEMENT » dans le Tableau 2 (réactivation des flux de restauration uniquement)

Pour les clients de Cloud DR PPDM :
Clients de PPDM version 19.8 : Mise à niveau vers Cloud DR 19.8.0.2
Clients de PPDM version 19.7 : Mise à niveau vers Cloud DR 19.7.0.2
Clients de PPDM version 19.6 : Mise à niveau vers Cloud DR 19.6.0.2
Clients de PPDM version 19.5 : Mise à niveau vers Cloud DR 19.5.0.2
Clients de PPDM version 19.2 : Mise à niveau vers Cloud DR 19.2.0.5
Clients de PPDM versions 19.3 et 19.4 : Mise à niveau vers Cloud DR 19.5.0.2 (instance de serveur Cloud DR)

Pour les clients de Cloud DR RecoverPoint for VM :
Clients de RecoverPoint for VM version 5.3.2 : Mise à niveau vers Cloud DR 19.7.0.2
Clients de RecoverPoint for VM version 5.3.1 : Mise à niveau vers Cloud DR 19.6.0.2
Clients de RecoverPoint for VM version 5.2.x : Mise à niveau vers Cloud DR 19.5.0.2

Pour les clients de Standalone Cloud DR :
Correctifs de mise à niveau disponibles pour Standalone Cloud DR : 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 et 19.1.0.6
Les clients de Standalone Cloud DR 19.3 et 19.4 concernés doivent effectuer une mise à niveau vers Cloud DR 19.5.0.2 ou une version ultérieure

Tous les packages d’installation ou de mise à niveau de Cloud DR sont disponibles à l’adresse suivante :
https://www.dell.com/support/home/fr-fr/product-support/product/data-domain-cloud-dr-for-avamar/drivers


Tableau 2
Solution de contournement pour les clients qui choisissent de ne pas appliquer les correctifs Cloud DR détaillés dans le Tableau 1.
 
Produit (système d’exploitation ou environnement d’exploitation)
  • Cloud Disaster Recovery (Cloud DR) version 19.8 et versions antérieures avec AWS ou AWS GovCloud
  • Tous les produits associés à Cloud DR avec AWS ou AWS GovCloud peuvent être affectés par ce problème
    • Appliances PowerProtect DP
    • PowerProtect Data Manager (PPDM)
    • Standalone Cloud DR (PowerProtect DD ou Data Domain et Avamar)
    • RecoverPoint for VMs
TYPE D’ACTION SOLUTION
Qui peut effectuer l’action ? CLIENT
Détails de la résolution SOLUTION DE CONTOURNEMENT :

Évitez de supprimer Cloud DR Server (CDRS) ou tout composant Cloud DR exécuté dans le Cloud.

Détails de la solution de contournement pour le nouveau déploiement de Cloud DR Server :
Solution de contournement pour les clients des appliances PowerProtect DP/IDPA, PowerProtect Data Manager et RecoverPoint for VMs exécutant des versions existantes qui n’incluent pas les correctifs Cloud DR corrigés pour permettre le déploiement de Cloud DR Server vers AWS et AWS GovCloud

Informations sur la solution de contournement :
Utilisation d’un module complémentaire Cloud DR externe (CDRA) pour déployer CDRS sur AWS ou AWS GovCloud et connecter ultérieurement l’appliance PowerProtect DP, PPDM ou RecoverPoint for VM à cette instance CDRS.

Étapes de cette solution de contournement :
  1. Déployez la machine virtuelle CDRA à l’aide du nouveau module d’installation du correctif de la version Cloud DR requise.
  2. À partir de l’interface utilisateur de CDRA, déployez CDRS dans la région AWS ou AWS GovCloud requise.
  3. Connectez l’appliance PowerProtect DP, PPDM ou RecoverPoint for VM à CDRS.
  4. Retirez la machine virtuelle temporaire CDRA autonome :
    1. Dans l’option de menu CDRS System, sélectionnez Registered Components.
    2. Sélectionnez le CDRA temporaire, puis cliquez sur Unregister.
    3. Mettez hors tension la machine virtuelle temporaire CDRA.
    4. Supprimez la machine virtuelle temporaire CDRA.

Solution de contournement pour les clients qui ne peuvent pas mettre à niveau leur CDRS existant à l’aide des correctifs publiés pour réactiver les workflows de récupération Cloud DR :

Nettoyez tous les messages existants des files d’attente SQS pertinentes :
  1. Purgez les messages de la console :
    1. Connectez-vous à la console AWS.
    2. Sélectionnez la région appropriée.
    3. Accédez à Services > SQS (Simple Queue Service).
    4. Sélectionnez les files d’attente RestoreService (en commençant par CDRS-RestoreService) où le nombre de messages disponibles est supérieur à zéro (une par une).
    5. Cliquez sur Action et purgez-les pour effacer tous les messages de la file d’attente.
    6. Écrivez « purge » dans la zone de confirmation, puis cliquez sur le bouton Purge (Purger).
  2. Mettez fin à toutes les instances RestoreService :
    1. Connectez-vous à la console AWS.
    2. Sélectionnez la région appropriée.
    3. Accédez à Services > EC2 (Amazon EC2) > Auto Scaling groups (Groupes de mise à l’échelle automatique).
    4. Filtrez les groupes de mise à l’échelle automatique (en commençant par CDRS-RestoreService).
    5. Sélectionnez le groupe Auto Scaling dont la valeur Desired capacity (Capacité souhaitée) est supérieure à zéro.
    6. Cliquez sur le bouton Modifier, définissez la capacité souhaitée sur zéro, puis cliquez sur le bouton Mettre à jour. Cette opération met fin à toutes les instances RestoreService.
  3. Mettez à jour la pile RestoreService CF pour utiliser une version spécifique de la CLI v1 :
    1. Connectez-vous à la console AWS.
    2. Sélectionnez la région appropriée.
    3. Accédez à Services > CloudFormation > Stacks.
    4. Désélectionnez le bouton View Nested.
    5. Filtrez la pile RestoreService affectée (en commençant par CDRS-RestoreService).
    6. Cliquez sur la pile CDRS-RestoreService et accédez à la section Parameters.
    7. Copiez la chaîne chiffrée InstanceUserData dans un outil de déchiffrement en ligne (par exemple https://www.base64decode.org/) et décodez cette chaîne.
    8. Modifiez les deux lignes suivantes dans le script déchiffré :
FROM
    wget https://s3.amazonaws.com/aws-cli/awscli-bundle.zip
    unzip awscli-bundle.zip
 TO
    wget https://s3.amazonaws.com/aws-cli/awscli-bundle-1.18.200.zip
    unzip awscli-bundle-1.18.200.zip
  1. Encodez (à l’aide de https://www.base64encode.org/) le script décodé complet mis à jour vers base64 et copiez la chaîne chiffrée.
  1. Accédez à la console AWS, cliquez sur le bouton Update dans la pile, puis sélectionnez le bouton radio Use Current Template et cliquez sur Next.
  2. Dans Paramètres, remplacez la valeur du champ InstanceUserData par la nouvelle chaîne chiffrée (copiée à l’étape i).
  3. Cliquez sur Next, puis à nouveau sur Next, activez les cases à cocher des accusés de réception, puis cliquez sur le bouton Update Stack.
  4. Enregistrez la modification et attendez que la pile termine son processus de mise à jour interne. Cette étape devrait permettre de mettre à jour toutes les piles imbriquées.
  1. Vérifiez que les flux DR et la création de copies Rapid Recovery peuvent désormais progresser et se terminer avec succès.
  2. La rétention doit désormais réussir.

Produits concernés

Cloud Disaster Recovery
Propriétés de l’article
Numéro d’article: 000189732
Type d’article: Solution
Dernière modification: 27 août 2022
Version:  9
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