Cloud Disaster Recovery : La suppression par Amazon Web Services (AWS) de la prise en charge de Python 2.7 au 15 juillet 2021 peut avoir un impact sur les clients Cloud Disaster Recovery, ce qui entraîne potentiellement une indisponibilité des données.
Résumé: Depuis le 15 juillet 2021, AWS ne prend plus en charge Python 2.7 dans la CLI AWS, ce qui peut entraîner des problèmes pour Cloud DR.
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Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
Depuis le 15 juillet 2021, AWS ne prend plus en charge Python 2.7 dans la CLI AWS, ce qui entraîne les problèmes suivants pour Cloud DR :
Produits :
Tous les produits associés à Cloud DR sont concernés par ce problème (appliances PowerProtect DP, PPDM, Standalone Cloud DR et RecoverPoint for VM).
Clients :
Tous les clients Cloud DR utilisant AWS ou AWS GovCloud comme Cloud cible sont affectés.
Fonctionnalité :
Nouvelles installations Cloud DR :
Solution de contournement :
Le nouveau déploiement de Cloud DR Server dans AWS ou AWS GovCloud nécessite l’utilisation d’un nouveau module d’installation de l’un des nouveaux correctifs publiés.
- Nouveaux déploiements de toutes les versions de Cloud DR
- Déploiements existants :
- Exécution de la récupération sur toutes les versions de Cloud DR Rétention sur les versions 19.7 et 19.8
Produits :
Tous les produits associés à Cloud DR sont concernés par ce problème (appliances PowerProtect DP, PPDM, Standalone Cloud DR et RecoverPoint for VM).
Clients :
Tous les clients Cloud DR utilisant AWS ou AWS GovCloud comme Cloud cible sont affectés.
Fonctionnalité :
Nouvelles installations Cloud DR :
- Échec du déploiement du CDRS dans AWS ou AWS GovCloud (impactant toutes les versions de Cloud DR).
- Échec de l’exécution des flux de récupération dans AWS ou AWS GovCloud (problème concernant toutes les versions de Cloud DR).
- Échec de l’exécution des flux de rétention dans AWS ou AWS GovCloud (problème concernant les versions 19.7 et 19.8 de Cloud DR).
- Les déploiements Cloud DR existants, qui peuvent toujours exécuter la protection vers AWS ou AWS GovCloud.
- Les clients Cloud DR utilisant des solutions Cloud Azure et Azure Government.
Solution de contournement :
Le nouveau déploiement de Cloud DR Server dans AWS ou AWS GovCloud nécessite l’utilisation d’un nouveau module d’installation de l’un des nouveaux correctifs publiés.
Cause
Le problème est dû à l’arrêt de la prise en charge de Python 2.7 par AWS. Consultez les informations relatives à Amazon EOS :
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/.
https://aws.amazon.com/blogs/developer/announcing-end-of-support-for-python-2-7-in-aws-sdk-for-python-and-aws-cli-v1/.
Résolution
Voici les deux options de résolution pour les clients concernés : le Tableau 1 propose de nouveaux correctifs de déploiement et de mise à niveau ; le Tableau 2 propose une solution de contournement comme alternative aux clients qui ne choisissent pas de procéder à une mise à niveau.
Tableau 1
Tableau 2
Solution de contournement pour les clients qui choisissent de ne pas appliquer les correctifs Cloud DR détaillés dans le Tableau 1.
Tableau 1
| Produit (système d’exploitation ou environnement d’exploitation) |
|
| Problème résolu dans ce système d’exploitation, cet environnement d’exploitation ou ce logiciel | Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 et 19.1.0.6 |
| TYPE D’ACTION | MISE À NIVEAU |
| Qui peut effectuer l’action ? | CLIENT |
| Détails de la résolution | Pour le nouveau déploiement de Cloud DR : Mettre à niveau (ou utiliser) Cloud DR 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2 ou 19.2.0.5 Pour les clients Cloud DR PowerProtect ou IDPA : Clients de IDPA version 2.6.1 : Mise à niveau vers Cloud DR 19.6.0.2 Clients de IDPA version 2.6.0 : Mise à niveau vers Cloud DR 19.5.0.2 Clients de IDPA version 2.5.0 : Mise à niveau vers Cloud DR 19.2.0.5 Clients de IDPA versions 2.4.1 et 2.3.1 : Mise à niveau vers Cloud DR 19.1.0.6 Remarque : Clients d’IDPA versions 2.4.0 et 2.3.0 : consultez la section « SOLUTION DE CONTOURNEMENT » dans le Tableau 2 (réactivation des flux de restauration uniquement) Pour les clients de Cloud DR PPDM : Clients de PPDM version 19.8 : Mise à niveau vers Cloud DR 19.8.0.2 Clients de PPDM version 19.7 : Mise à niveau vers Cloud DR 19.7.0.2 Clients de PPDM version 19.6 : Mise à niveau vers Cloud DR 19.6.0.2 Clients de PPDM version 19.5 : Mise à niveau vers Cloud DR 19.5.0.2 Clients de PPDM version 19.2 : Mise à niveau vers Cloud DR 19.2.0.5 Clients de PPDM versions 19.3 et 19.4 : Mise à niveau vers Cloud DR 19.5.0.2 (instance de serveur Cloud DR) Pour les clients de Cloud DR RecoverPoint for VM : Clients de RecoverPoint for VM version 5.3.2 : Mise à niveau vers Cloud DR 19.7.0.2 Clients de RecoverPoint for VM version 5.3.1 : Mise à niveau vers Cloud DR 19.6.0.2 Clients de RecoverPoint for VM version 5.2.x : Mise à niveau vers Cloud DR 19.5.0.2 Pour les clients de Standalone Cloud DR : Correctifs de mise à niveau disponibles pour Standalone Cloud DR : 19.8.0.2, 19.7.0.2, 19.6.0.2, 19.5.0.2, 19.2.0.5 et 19.1.0.6 Les clients de Standalone Cloud DR 19.3 et 19.4 concernés doivent effectuer une mise à niveau vers Cloud DR 19.5.0.2 ou une version ultérieure Tous les packages d’installation ou de mise à niveau de Cloud DR sont disponibles à l’adresse suivante : https://www.dell.com/support/home/fr-fr/product-support/product/data-domain-cloud-dr-for-avamar/drivers |
Tableau 2
Solution de contournement pour les clients qui choisissent de ne pas appliquer les correctifs Cloud DR détaillés dans le Tableau 1.
| Produit (système d’exploitation ou environnement d’exploitation) |
|
| TYPE D’ACTION | SOLUTION |
| Qui peut effectuer l’action ? | CLIENT |
| Détails de la résolution | SOLUTION DE CONTOURNEMENT : Évitez de supprimer Cloud DR Server (CDRS) ou tout composant Cloud DR exécuté dans le Cloud. Détails de la solution de contournement pour le nouveau déploiement de Cloud DR Server : Solution de contournement pour les clients des appliances PowerProtect DP/IDPA, PowerProtect Data Manager et RecoverPoint for VMs exécutant des versions existantes qui n’incluent pas les correctifs Cloud DR corrigés pour permettre le déploiement de Cloud DR Server vers AWS et AWS GovCloud Informations sur la solution de contournement : Utilisation d’un module complémentaire Cloud DR externe (CDRA) pour déployer CDRS sur AWS ou AWS GovCloud et connecter ultérieurement l’appliance PowerProtect DP, PPDM ou RecoverPoint for VM à cette instance CDRS. Étapes de cette solution de contournement :
Solution de contournement pour les clients qui ne peuvent pas mettre à niveau leur CDRS existant à l’aide des correctifs publiés pour réactiver les workflows de récupération Cloud DR : Nettoyez tous les messages existants des files d’attente SQS pertinentes :
FROM
wget https://s3.amazonaws.com/aws-cli/awscli-bundle.zip unzip awscli-bundle.zip TO wget https://s3.amazonaws.com/aws-cli/awscli-bundle-1.18.200.zip unzip awscli-bundle-1.18.200.zip
|
Produits concernés
Cloud Disaster RecoveryPropriétés de l’article
Numéro d’article: 000189732
Type d’article: Solution
Dernière modification: 27 août 2022
Version: 9
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